Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

unable to load class net.sourceforge.texlipse

Help
2012-12-18
2013-10-16
  • I keep seeing this error message when trying to open my latex files in eclipse:

    Plug-in net.sourceforge.texlipse was unable to load class net.sourceforge.texlipse.editor.TexEditor.

    I don't know what to do. Is anyone else experiencing the same problems?

     
  • svarni
    svarni
    2013-10-16

    I was experiencing this problem, too, but only after closing eclipse with my project and tex files open. After restart, no tex files could be displayed.
    I hope I can still help you after such a long time.

    After searching the web and browsing through the very long exception cascade (reading something about 'deriving file extension') I figured out:

    You need to specify a valid filename as user dictionary for the eclipse spellchecker under
    General | Editors | Text Editors | Spelling,
    even though you might have specified dictionaries under
    Texlipse | Spell Checker.

    To fully resolve my problems I also reset the spellchecker settings for TeXlipse to default (retaining 'aspell' settings that I actually do not use, because I've set to use eclipses inbuild spellchecker). I also searched my
    workspace/.metadata/.plugins-Folder
    and removed any subfolders that matched 'tex', 'texlive' and 'texteditor'.
    After that I started eclipse with the "-clean" option by hand (don't even know what that option does ;)

    Until now, that problem did not occur again. I can close eclipse with my tex projects and files open. Afte restarting eclipse, everything is as it should be.

     
    Last edit: svarni 2013-10-16