Release 1.5.2 is out! Now compatible Trac 1.0

2012-10-14
2013-01-05
  • Release 1.5.2 is out, and this plugin is now compatible with Trac 1.0!!!

    Since the release of Trac 1.0, I had to split the plugins code into two versions:
    - a version that works well with Trac 0.11
    - a version that works well with Trac 0.12 and Trac 1.0

    All the code works with Python 2.5, 2.6 and 2.7.
    All database backends are supported.

    ********************
       IMPORTANT NOTE
    ********************
    Starting with this release, because of the code branch I had to do to support Trac 1.0, all new features will only be developed for Trac 0.12 or above.

    The 0.11 branch will only be supported for bug fixes.

    ===========================================

    Release 1.5.2 (2012-10-14):

      This release makes the plugins compatible with Trac 1.0.
     
      Since the release of Trac 1.0, I had to split the plugins code into
      two versions:
    - a version that works well with Trac 0.11
    - a version that works well with Trac 0.12 and Trac 1.0

      All the code still works with Python 2.5, 2.6 and 2.7.
      All database backends are still supported.

      To build from the source, refer to the updated BUILD.txt file. 

      o Fixed Ticket #10293 (Track-Hacks): New install impossible on Trac 1.0beta1
     
      o Fixed Ticket #10295 (Track-Hacks): Trac detected an internal error: UnicodeError: source returned bytes, but no encoding specified

     

     
  • Also updated the readme files for building, installing and upgrading.

    Refer to BUILD.txt, INSTALL.txt and UPGRADE.txt, respectively-

    Enjoy!!!

    If you wish, leave your feedback on using this plugin.

    Ciao,
    Roberto