Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1 doesn't work for Trac 0.12.1 on python 2.6.5?

open-invalid
nobody
None
5
2012-04-01
2012-02-07
Anonymous
No

after select eggs by wiki's (http://trac-hacks.org/wiki/TestManagerForTracPluginQuickSetup) order,and upgrade database by "trac-admin /var/lib/trac/foo upgrade",there is not test manager relate plugins on plugins list.
on the plugins folder, all eggs is uploaded successful
# ls foo/plugins/
TestManager-1.4.9-py2.7.egg TracGenericClass-1.1.1-py2.7.egg TracGenericWorkflow-1.0.3-py2.7.egg

Discussion

  • The provided egg files are built for Python 2.7 (notice the 2.7 number in the generated file name).

    To use with Python 2.6.5 you should build from the source code. I't's very easy: just cd into the unzipped source directory and run ". ./build.sh" from the shell.

    You will tyhen find the egg files in the "bin" subdirectory.

    Let me know if this works for you.

    Ciao,
    Roberto

     
    • status: open --> open-invalid
     
  • If you are using Pythoin 2.6.5, you shouldn't install the egg files for Python 2.7, which are the ones available for download.

    Instead, download the source code and build it on your server machine.

    Building is as simple as launching the build.sh script.

    Ciao,
    Roberto