#3 Cannot build tclreadline-2.1.0 on Mac OS X 10.4

open
nobody
None
5
2005-07-14
2005-07-14
Anonymous
No

The build makes *.la and *.lo files, instead of the
*.dylib files that Mac OS X requires. Using Apple's
'libtool' by hand to create the shared-libs, and
installing them by hand under /System/Library/Tcl
doesn't help. It finds the tclreadline files, loads
the extension, and prompts for one command, then exits
with an error.

$ tclsh
% package require tclreadline
2.1.0
% set tcl_version
8.4
%
% ::tclreadline::Loop
tclsh8.4 [~/Public/Ruby/tclreadline-2.1.0]set tcl_version
alloc: invalid block: 0x30b188: 72 0 0

Abort trap

Discussion