#288 no man page for library procedures Tcl_AddInterpResolver Tcl

obsolete: 8.1
open-fixed
4
2006-03-19
2000-10-26
Anonymous
No

OriginalBugID: 1814 Bug
Version: 8.1
SubmitDate: '1999-04-14'
LastModified: '1999-04-28'
Severity: MED
Status: Closed
Submitter: admin
ChangedBy: kenj
OS: All
OSVersion: NA
Machine: NA
FixedDate: '2000-10-25'
FixedInVersion: NA
ClosedDate: '1999-04-28'

04/28/1999 14:46 - kenj - These are not public APIs (they appear in tclInt.h, not tcl.h).

Discussion

  • Brent B. Welch
    Brent B. Welch
    2000-10-26

    • priority: 5 --> 2
    • status: open --> closed-fixed
     
  • Don Porter
    Don Porter
    2001-04-04

    Logged In: YES
    user_id=80530

    Re-opened. Either Tcl_AddInterpResolvers() should be
    private and has an incorrect name, or it should be
    public, and we should convert this bug report into a
    Feature Request to make that happen.

     
  • Don Porter
    Don Porter
    2001-04-04

    • labels: 104240 --> 21. [namespace]
    • status: closed-fixed --> open-fixed
     
    • assigned_to: nobody --> andreas_kupries
     
  • Don Porter
    Don Porter
    2004-03-03

    • milestone: 102424 --> 102414
     
  • Don Porter
    Don Porter
    2004-03-03

    • milestone: 102414 --> obsolete: 8.1
     
  • Logged In: YES
    user_id=585068

    I wrote most of a manual page for this, but I was told in
    the Tcler's Chat that this resolver code would probably be
    replaced. If anyone wants the manual page let me know. I
    based it on comments in the resolver code and my own little
    test program that created a custom resolver.

     
  • Logged In: YES
    user_id=79902

    This API mistake has been festering since 8.0; there's no
    hurry to fix it. Indeed, if it slipped 8.5 I wouldn't worry
    at all.

    The problem is: is the interface this function and its
    friends expose the interface that we would like to expose?
    Is it something that perhaps we expose and deprecate? (I
    don't have answers; just questions.)

     
  • Logged In: YES
    user_id=75003

    George, feel free to attach the manpage here. Even if the
    code goes away such docs should help to make the
    determination if the api is wanted or not. Internal notes
    are of interest as well, IMHO.

     
  • Manpage

     
    Attachments
  • Sample resolver C sources

     
    Attachments
  • Logged In: YES
    user_id=75003

    I have retrieved manpage and sample code from the specified
    urls and attached them to this report.

     
    • priority: 2 --> 4
     
  • See also Bug #414930

     
  • Documentation would need to be beefed up before use to include the definition (and description of manner of use) of the types referred to.