#2626 Tcl Bug(?) causes aMSN crash

obsolete: 8.5a1
closed-invalid
miguel sofer
None
5
2014-08-21
2004-03-20
Anonymous
No

Correct me if I'm wrong, but I believe this error to be
caused by TCL and not aMSN itself. If I am incorrect,
please accept my apologies for this post.

Below is the error that aMSN logs:

------------------------------------------------------------------------------------

Bug generated at 03/20/04 - 02:03:55

Error : {too many nested evaluations (infinite loop?)}
Stack : too many nested evaluations (infinite loop?)
(procedure "timestamp" line 5)
invoked from within
"timestamp"

Code : NONE

tcl version : 8.5 ||| tk version : 8.5

tcl_platform array content : platform unix machine i686
user admin wordSize 4 byteOrder littleEndian osVersion
2.4.20-8 os Linux

------------------------------------------------------------------------------------

Discussion

  • Jeffrey Hobbs
    Jeffrey Hobbs
    2004-03-20

    • status: open --> closed
     
  • Jeffrey Hobbs
    Jeffrey Hobbs
    2004-03-20

    Logged In: YES
    user_id=72656

    The error is spit out by Tcl, but not caused by it.
    Something is causing an infinite loop, likely the command
    timestamp (does it call itself?), which is not a core command.

     
  • Jeffrey Hobbs
    Jeffrey Hobbs
    2004-03-20

    • status: closed --> closed-invalid
     
  • miguel sofer
    miguel sofer
    2004-03-20

    • assigned_to: nobody --> msofer
    • status: closed-invalid --> closed-invalid
     
  • miguel sofer
    miguel sofer
    2004-03-20

    Logged In: YES
    user_id=148712

    (1) next time please do login at SF or leave contact info
    with the bug report, so that we can request further info

    (2) as Jeff said, this looks a priori like a bug in aMSN.

    What is [timestamp]'s business in calling itself recursively
    at line 5, as per the error message? This is weird coding
    for a timestamp proc, a more reasonable one would schedule
    itself with [after] instead of recursing.
    Please report it at aMSN

    Should this be a tclbug, we will need a bit more details to
    hunt it down - probably with the helpof the aMSN developers.

     
  • Don Porter
    Don Porter
    2004-03-20

    Logged In: YES
    user_id=80530

    This might not be simply [timestamp]
    calling itself. (Line 5 of the [timestamp]
    proc is where the recursion limit is
    hit, but the stack trace doesn't tell us
    whether that's a nested [timestamp]
    call.) Another possibility is that a
    large number of event loops are getting
    nested. This would happen if some
    event handlers called their own event
    loops using something like [update] or
    a nested [vwait].

    See the "Update considered harmful"
    Wiki page for discussion of this issue.

    http://wiki.tcl.tk/1255