#2196 fCmd-8.2 fails with stow

obsolete: 8.4.1
closed-fixed
Don Porter
8
2003-10-06
2003-02-13
Benoît Sibaud
No

all.tcl: Total 9063 Passed 8303 Skipped
758 Failed 2
Sourced 121 Test Files.
Files with failing tests: fCmd.test http.test
Number of tests skipped for each constraint:
15 95
13 doTestsWithRemoteServer
48 emptyTest
1 globTest/.1
2 hasIsoLocale
28 knownBug
1 knownbug
25 localeRegexp
130 macOnly
1 needPST
153 nonPortable
1 notInstalledInTmp
2 notWin2000
12 nt
312 pcOnly
1 umask2
2 unixOnly && !testthread
3 unknownFailure
3 win2000
5 xdev

tested on 5 plateforms in a stow environment
(i686-pc-linux-gnu,sparc-unknown-linux-gnu,
sparc-sun-solaris2.6|7|8).
with gcc-3.2.2

./configure \ --prefix=${SHOP_STOW}/${SHOP_PACKAGE} \
--exec-prefix=${SHOP_STOW}/${SHOP_PACKAGE}/${SHOP_CONFIG}
\ --enable-gcc \ --enable-shared \ --enable-threads

Discussion

  • Don Porter
    Don Porter
    2003-02-13

    • status: open --> pending
     
  • Don Porter
    Don Porter
    2003-02-13

    • status: pending --> pending-duplicate
     
  • Don Porter
    Don Porter
    2003-02-13

    • labels: 104251 -->
     
  • Don Porter
    Don Porter
    2003-02-13

    Logged In: YES
    user_id=80530

    This report is useless unless you tell us
    which tests failed. Better yet, tell us
    how they failed.

    I'm going to guess that http-4.14 failed.
    That's a duplicate of Bug 529661, among
    others.

    I'll also guess that fCmd-18.10 failed.
    That's a duplicate of Bug 456665,
    among others.

    If I've guessed wrong, followup with
    more details. Otherwise, this will
    close as a duplicate report.

     
  • Benoît Sibaud
    Benoît Sibaud
    2003-02-14

    • status: pending-duplicate --> open-duplicate
     
  • Benoît Sibaud
    Benoît Sibaud
    2003-02-14

    Logged In: YES
    user_id=27227

    It seems fCmd-8.2 failed because the user is shopadm (stow
    environment) and its home is /export/shop.

    http-4.14 failed due to badurl = www.scriptics.com:6666
    (proxy error/timeout I suppose). Test is OK with
    badurl=existing_machine.localdomain:6666

    And in fact, I got a third error on Sparc Linux (and only on
    this platform)

    ==== timer-6.29 Tcl_AfterCmd procedure, info option, script
    with NULL FAILED
    ==== Contents of test case:

    foreach i [after info] {
    after cancel $i
    }
    set x "hello world"
    set id junk
    set id [after 10 set x ab\0cd]
    update
    set y [string length [lindex [lindex [after info $id] 0] 2]]
    foreach i [after info] {
    after cancel $i
    }
    set y

    ==== Test generated error:
    event "after#60" doesn't exist
    ---- Result should have been:
    5
    ==== timer-6.29 FAILED

     
  • Don Porter
    Don Porter
    2003-02-14

    Logged In: YES
    user_id=80530

    passing th fCmd-8.2 failure on
    to the FileSystem maintainer.

    I think stow makes much use
    of symlinks, so this may indicate
    a symlink problem. Can the
    submitter verify this problem
    still occurs in an 8.4 release?

    Note that 8.4 may have other
    problems with stow. See Bug
    573292.

    Please re-submit the timer-6.29
    failure as another report in the
    Timer Events category.

    Thanks for the multi-platform testing.

     
  • Don Porter
    Don Porter
    2003-02-14

    • summary: fCmd.test and http.test failures with 8.3.5 --> fCmd-8.2 fails with stow
    • assigned_to: dgp --> vincentdarley
    • milestone: --> 248896
    • labels: --> 37. File System
    • status: open-duplicate --> open-remind
     
  • Vince Darley
    Vince Darley
    2003-02-16

    Logged In: YES
    user_id=32170

    This really needs to be re-run against Tcl 8.4.2 for the
    bug report to be at all meaningful or helpful as a
    filesystem bug report. Lowering priority until such a
    time as that happens.

     
  • Vince Darley
    Vince Darley
    2003-02-16

    • priority: 5 --> 3
     
  • Benoît Sibaud
    Benoît Sibaud
    2003-02-17

    • milestone: 248896 --> obsolete: 8.4.1
     
  • Benoît Sibaud
    Benoît Sibaud
    2003-02-17

    Logged In: YES
    user_id=27227

    Tested with 8.4.1. Same failure.

    I think I was unclear. I'm not at all a Tcl programer, but
    it seems the fCmd 8.2 test is a match between the user
    directory name and the user name.

    Two tests:
    shopadm user, with $HOME=/export/shop => failure
    shopadm user, with $HOME=/export/shopadm => success
    (it did the test with a shopadm/ symlink on shop/ and a
    change in /etc/passwd). I don't think it's stow related at
    all. The fCmd 8.2 test seems to be based on the false
    assumption a user directory is already named as the user.

     
  • Vince Darley
    Vince Darley
    2003-02-17

    • assigned_to: vincentdarley --> hobbs
     
  • Vince Darley
    Vince Darley
    2003-02-17

    Logged In: YES
    user_id=32170

    Thanks for the clarification. What you say makes sense,
    but I'm not sure of how to change the test...

    Jeff: any ideas?

     
  • Don Porter
    Don Porter
    2003-02-17

    Logged In: YES
    user_id=80530

    The test is apparently there
    to check that lines 793-799
    of generic/tclFCmd.c run
    correctly, but the test tests
    too much, making the
    unwarrented assumption
    described by the OP.

    Adjust the test so that it
    just tests what it needs to.

     
  • Don Porter
    Don Porter
    2003-02-17

    Logged In: YES
    user_id=80530

    It appears that if you
    limit the test to its
    essentials, you can
    remove the unixOnly
    and notRoot constraints
    as well.

     
  • Don Porter
    Don Porter
    2003-10-02

    • priority: 3 --> 8
    • assigned_to: hobbs --> dgp
     
  • Don Porter
    Don Porter
    2003-10-06

    • assigned_to: dgp --> vincentdarley
     
  • Don Porter
    Don Porter
    2003-10-06

    Logged In: YES
    user_id=80530

    this one needs maintainer knowledge

     
  • Vince Darley
    Vince Darley
    2003-10-06

    • assigned_to: vincentdarley --> dgp
     
  • Vince Darley
    Vince Darley
    2003-10-06

    Logged In: YES
    user_id=32170

    The test is really just to check that when given a path
    composed of a single element beginning with '~', that Tcl
    expands that path before returning the tail. As far as the
    result is concerned, all that is really desired is that the
    result is not the same as the input, so:

    file tail foo == foo
    file tail ~user != ~user

     
  • Don Porter
    Don Porter
    2003-10-06

    • status: open-remind --> closed-remind
     
  • Don Porter
    Don Porter
    2003-10-06

    • status: closed-remind --> closed-fixed
     
  • Don Porter
    Don Porter
    2003-10-06

    Logged In: YES
    user_id=80530

    thanks.