Linux versions prior to 2.6.35 can launch with early versions of tboot, but for the latest tboot and all features (e.g. S3), you need 2.6.35+.

 

Joe

 

From: Ning Qu [mailto:quning@gmail.com]
Sent: Wednesday, February 15, 2012 11:53 AM
To: Cihula, Joseph
Cc: tboot-devel@lists.sourceforge.net
Subject: Re: [tboot-devel] is that possible to use tboot with Linux kernel only?

 

Hi, Thanks for all the info, guys!!

 

So Joseph, you mentioned 2.6.35+ required. Is that because of any changes in tboot recently? Since Charles thinks 2.6.20+ should be fine .... Just want to be sure before diving into it again :)

 

Best wishes,
--
Ning Qu

On Wed, Feb 15, 2012 at 8:15 AM, Cihula, Joseph <joseph.cihula@intel.com> wrote:

Tboot works fine with a Linux kernel that supports it (2.6.35+).  You can find more details on it in the kernel source tree at Documentation/intel_txt.txt.

 

Joe

 

From: Ning Qu [mailto:quning@gmail.com]

Sent: Tuesday, February 14, 2012 5:43 PM
To: tboot-devel@lists.sourceforge.net

Subject: [tboot-devel] is that possible to use tboot with Linux kernel only?

 

Just read through the readme, seems right now Xen is required ... Any one tried to use tboot with Linux Kernel only scenario?

 

Thanks!