Ross,

 

I added the ‘-ltspi’ dependency when I removed TrouSerS in order to give a user who does not have TrouSerS installed a better error message (otherwise they get the missing header file error followed by a screenful of missing identifiers.  This just provides a single error that libtspi is missing.

 

How are you seeing this failing?

 

Joe

 

From: Ross Philipson [mailto:Ross.Philipson@citrix.com]
Sent: Thursday, January 14, 2010 6:39 AM
To: tboot-devel@lists.sourceforge.net
Subject: [tboot-devel] [PATCH] Fix lcptools makefile

 

Patch attached:

 

The removal of Trousers from the build introduced a build issue in the lcptools/Makefile where –ltspi is listed as a build target and causes building to fail.

 

Signed-off-by: Ross Philipson ross.philipson@citrix.com