GD-0912-R "Could not Initialize"

Help
2012-03-14
2013-05-30
  • ScottishCalvin
    ScottishCalvin
    2012-03-14

    eMac PPC G4  OSX 10.5.8

    I acquired the eMac and Tablet (Wacom GD-0912-R) and purchased an adaptor on eBay which seems to be spotted:

      Product ID:   0x2303
      Vendor ID:    0x067b  (Prolific Technology, Inc.)
      Version:  3.00
      Speed:    Up to 12 Mb/sec
      Manufacturer: Prolific Technology Inc.
      Location ID:  0x18200000
      Current Available (mA):   500
      Current Required (mA):    100
    

    However, it doesn't seem to pick up anything.

    14/3/12 22:11:46 [0x0-0x12012].com.apple.systempreferences[112] TabletMagicDaemon v2.0b18 
    14/3/12 22:11:46 [0x0-0x12012].com.apple.systempreferences[112] (c) 2001-2011 Thinkyhead Software <www.thinkyhead.com> 
    14/3/12 22:11:46 [0x0-0x12012].com.apple.systempreferences[112] [INIT] renice -20 319 : Succeeded 
    14/3/12 22:11:55 [0x0-0x12012].com.apple.systempreferences[112] [INIT] Machine Type: PowerMac4,4 
    14/3/12 22:11:56 System Preferences[112] Received [hello] 
    14/3/12 22:11:56 System Preferences[112] Received [port] usbserial 
    14/3/12 22:11:56 System Preferences[112] Received [none] 
    14/3/12 22:11:56 System Preferences[112] Received [none] 
    14/3/12 22:11:55 [0x0-0x12012].com.apple.systempreferences[112] [PROC] Tablet Bounds: (0, 0) - (15239, 15239) 
    14/3/12 22:11:55 [0x0-0x12012].com.apple.systempreferences[112] [PROC] Screen Bounds: (0, 0) - (1599, 1199) 
    14/3/12 22:11:55 [0x0-0x12012].com.apple.systempreferences[112] [PORT] usbserial: OPENED 
    14/3/12 22:11:55 [0x0-0x12012].com.apple.systempreferences[112] [PORT] Setting speed to 9600 
    14/3/12 22:11:55 [0x0-0x12012].com.apple.systempreferences[112] [SENT] "SP\r" 
    14/3/12 22:11:55 [0x0-0x12012].com.apple.systempreferences[112] [SENT] "~#\r" 
    14/3/12 22:11:55 [0x0-0x12012].com.apple.systempreferences[112] [SENT] "~#\r" 
    14/3/12 22:11:56 [0x0-0x12012].com.apple.systempreferences[112] [SENT] "~#\r" 
    14/3/12 22:11:56 [0x0-0x12012].com.apple.systempreferences[112] [PORT] Setting speed to 19200 
    14/3/12 22:11:56 [0x0-0x12012].com.apple.systempreferences[112] [SENT] "SP\r" 
    14/3/12 22:11:56 [0x0-0x12012].com.apple.systempreferences[112] [SENT] "~#\r" 
    14/3/12 22:11:56 [0x0-0x12012].com.apple.systempreferences[112] [SENT] "~#\r" 
    14/3/12 22:11:56 [0x0-0x12012].com.apple.systempreferences[112] [SENT] "~#\r" 
    14/3/12 22:11:56 [0x0-0x12012].com.apple.systempreferences[112] Could not initialize tablet.
    

    I've spent an evening looking through forums talking about different adaptor settings but frankly, I'm cautious about fiddling about there and not even sure if that's where the problem would be anyway.   It's also a PPC machine rather than Intel and I'm not sure if the advice is the same for that old a machine, even if I have it running OS10.5.   As it is, the machine and tablet were free and I'd dearly love to make them both useful again.

     
  • ScottishCalvin
    ScottishCalvin
    2012-03-17

    Still the same problem, very slight differences in the output screen.  I tried playing about with a few of the Setup options but I just get  /Library/PreferencePanes/TabletMagic.prefPane/Contents/Resources/TabletMagicDaemon SendCommandToTablet Error 9: Bad file descriptor.
    I'm thinking I might see if I can grab a serial mouse or something from work on Monday and double check the port is definitely working fine. 

    17/3/12 15:27:10 .com.apple.systempreferences TabletMagicDaemon v2.0b17d2
    17/3/12 15:27:10 .com.apple.systempreferences (C) 2001-2009 Thinkyhead Software <www.thinkyhead.com>
    17/3/12 15:27:10 .com.apple.systempreferences  renice -20 128 : Succeeded
    17/3/12 15:27:18 .com.apple.systempreferences  Tablet Bounds: (0, 0) - (15239, 15239)
    17/3/12 15:27:18 .com.apple.systempreferences  Screen Bounds: (0, 0) - (1599, 1199)
    17/3/12 15:27:18 .com.apple.systempreferences  usbserial: OPENED
    17/3/12 15:27:18 .com.apple.systempreferences  Setting speed to 9600
    17/3/12 15:27:18 .com.apple.systempreferences  "SP\r"
    17/3/12 15:27:18 .com.apple.systempreferences  "~#\r"
    17/3/12 15:27:19 System Preferences Received 
    17/3/12 15:27:19 System Preferences Received  usbserial
    17/3/12 15:27:19 System Preferences Received 
    17/3/12 15:27:19 System Preferences Received 
    17/3/12 15:27:18 .com.apple.systempreferences  "~#\r"
    17/3/12 15:27:18 .com.apple.systempreferences  "~#\r"
    17/3/12 15:27:18 .com.apple.systempreferences  Setting speed to 19200
    17/3/12 15:27:18 .com.apple.systempreferences  "SP\r"
    17/3/12 15:27:18 .com.apple.systempreferences  "~#\r"
    17/3/12 15:27:18 .com.apple.systempreferences  "~#\r"
    17/3/12 15:27:18 .com.apple.systempreferences  "~#\r"
    17/3/12 15:27:19 .com.apple.systempreferences Could not initialize tablet.
    17/3/12 15:27:19 .com.apple.systempreferences Could not initialize tablet.

     
  • Scott Lahteine
    Scott Lahteine
    2012-03-19

    The next thing to try is some alternative PL-2303 drivers. Check out the list of links I have posted at http://www.thinkyhead.com/tabletmagic/adapters . Older drivers might be tricky to find. Prolific has some posted on their own site. There's an old Sourceforge project that is probably suited to PPC. Recently others have built this for Lion, and I doubt those new builds include PPC support.

     
  • ScottishCalvin
    ScottishCalvin
    2012-04-23

    Success!

    I decided to try out a new cable; the one I had was very cheap and from eBay,  I went to Maplin (a UK shop like Radio Shack) and got their own-brand one, keeping the receipt just in case.  The instructions said PL2303 which did not bode well but after cleaning out the old drivers and installing their ones, it works!  Curiously it did not work on the Automatic setting but did on the usbserial one.

    Overall this looks a fantastic piece of software, I've donated 10 bucks to buy some beers with.