Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

How to sync in one direction only ?

halt2010
2013-03-03
2015-03-08
  • halt2010
    halt2010
    2013-03-03

    Hello,

    I am syncing two folders. I don't want Synkron to copy any new files to the first folder, because the second one is a backup of the first and I want to keep there any files I want without getting them back to the first folder.
    Can I do this? If yes, how ?

     
    • Daniel
      Daniel
      2014-01-09

      Did you set Master and Slave in front of the folders?

       
  • I also use synkron, great soft, and i have the same question.
    I want to use it as a backup tool but i didn't find out how to make a one way copy (from a local disk to a network place.
    Every time i delete a file from the local disk, synkron will restore it in its original place.
    Is there a way to setup this ?
    Halt2012, did you find out how to get it work this one direction way ?
    Thks,
    André

     
  • pantera
    pantera
    2013-07-07

    I have the same question, but seems that the answer is the function PROPAGATE DELETIONS, that can be found in the menu TAB - ADVANCED - PROPAGATE DELETIONS.

    I am NOT SURE! Give a look at https://sites.google.com/site/synkrondocumentation/faq and, most important, TEST IT.

     
  • Dredbeard
    Dredbeard
    2013-08-31

    One method I am using is to select/check advanced options of the Origin/master folder to "Do not modify the contents of this folder".

    The other method which I am testing is to analyze and uncheck the files not to be deleted in the origin folder. This is taking an extraordinary amount of time though and may not be viable to multiple files.

     
  • Joey Daly
    Joey Daly
    2013-11-06

    Anyone got this working? I've tried the above solutions and none of them seem to really work. Synkron keeps wanting to Sync Folder 2 (Slave) with Folder 1 (Master). When I have all my files in Folder 2, and I've got a new updated (single) file in Folder 1 in the correct tree structure, and instead of syncing one file it wants to sync both folders to have the same contents.

    For now, workaround is manually copy/pasting over the top - I'd love Synkron to do it as I can schedule n such.

     
  • Hello,

    It is working for me.

    The from should be Master and update existing file only. In advance, Propagate Deletion if you like to do so. So i set this up.

    The to should be slave

    That's it !

     
  • Thelonious
    Thelonious
    2015-03-08

    It works !
    This is what I did:
    - both the source and the destination as masters
    - source: do not change the contents of this folder
    This is it !