failed to connect to server: incompatible client 1.4

Help
Martin
2014-02-28
2014-03-01
  • Martin
    Martin
    2014-02-28

    I've been using synergy 1.4.10 server on Linux and synergy 1.4.15 client on OSX 10.9 without problems.

    After installing 1.4.16 client on OSX, I find that it won't start if not installed in 'Applications' folder. I never had problem running the older 1.4.15 in a custom folder not named 'Applications'. I also find that it requires accessibilty.

    So I decide to re-install 1.4.15. Now I have a weird problem: synergy server 1.4.10 in Linux complains (or at least synergy client 1.4.15 on OS X logs the warning):

    WARNING: failed to connect to server: incompatible client 1.4

    Both server and client are 1.4, and they always worked before attempting to upgrade then downgrade back the OSX client.

    Any configuration I need to clean up in OSX client to solve this problem?

     
  • s_ryper
    s_ryper
    2014-03-01

    Any issues relating to synergy 1.4.x or HIGHER versions post at https://groups.google.com/forum/#!forum/synergy-users
    or open an bug report at synergy-plus current project pages at http://synergy-foss.org/spit/issues/#page=1&results=25

    History note:
    These project pages (https://sourceforge.net/p/synergy2/) are for synergy v1.3.1 and previous versions

    synergy v1.3.1 - provided workable Win XP platform support and other platforms
    synergy v1.2.7 - last version supporting workable win98 and other platforms
    If you don't need the older versions migrate to latest 1.4 or higher on the new support pages mentioned above.

     
    Last edit: s_ryper 2014-03-01