I don't think it makes sense to add a feature like this. We should just address #79 directly, e.g. by generating names which won't clash with PHP functions (e.g. prefix with swig_).

These functions are really an implementation detail if you're generating class wrappers around them. And if you aren't generating class wrappers, then you can rename them as you see fit using %rename.