Upgraded to Ubuntu 7.10, "ia32-libs-gtk"

Fraoch
2007-10-27
2013-04-08
  • Fraoch
    Fraoch
    2007-10-27

    I successfully upgraded from Ubuntu 7.04 AMD64 to 7.10 AMD64.

    Everything worked fine, including the swiftweasel32-nocona-32bit-AMD64 version for Ubuntu 7.04.

    Now that I have the "proper" 7.10 I wanted to upgrade to the 7.10 .deb but I get a depdendency error, it's looking for ia32-libs-gtk which is no longer supported and doesn't seem to exist in any repo I can find.

    Any advice?  Should I keep my existing 7.04 install?  It appears to be working fine, but I'm worried about the next 7.10 swiftweasel version.

     
    • SticKK
      SticKK
      2007-10-27

      Thanks for bringing this to my attention. I have removed the present Gutsy deb files and will be releasing updated ones soon. It looks like the Ubuntu developers got rid of all the small ia32 packages and merged them into one giant monster ia32-libs.

       
    • Fraoch
      Fraoch
      2007-10-27

      Well thanks again stickk!  I'll wait for the new .deb and report back.

       
    • SticKK
      SticKK
      2007-10-28

      I have looked into this a little. This issue only effected the swiftweasel32 debs. I have uploaded 2 new ones. Swiftweasel32 is built for a howto on the ubuntu forums. If you or anyone else does a clean install of Gutsy you should follow that howto to avoid other issues. http://ubuntuforums.org/showthread.php?p=1174435

       
    • Fraoch
      Fraoch
      2007-11-13

      Hmm, it's come back for 2.0.0.9... :-(

      I have followed the howto, which helped for 2.0.0.8 but is not working this time, it appears to be reinstalling 2.0.0.8.

      Is the issue with Kilz's script or the Swiftweasel .deb?

      Many thanks, and sorry to be such a pain!

       
    • SticKK
      SticKK
      2007-11-14

      I just looked at the swiftweasel32-2.0.0.9_nocona-32bit_ubuntu_7.10_AMD64.deb and swiftweasel32-2.0.0.9_nocona-32bit-pango_ubuntu_7.10_AMD64.deb. They do not have a ia32-libs-gtk dependency.

       
    • Fraoch
      Fraoch
      2007-11-14

      Whoops, I missed the "7.10" part and downloaded swiftweasel32-2.0.0.9_nocona-32bit_ubuntu_AMD64.deb instead.

      The 7.10 version installs fine but doesn't run, I'll make another post about it.

      Thank you!