Post Installation Error - Control Panel > Output cache

2012-07-11
2014-04-09
  • Pavel Reyes
    Pavel Reyes
    2012-07-11

    Hi, it looks like a very promising app. Hopefully I can get it working. 1st of all I'm on a shared hosting account with Hostgator so I don't have SSH access. That means that I could not follow the installation guide completely. But otherwise it appeared as the installation completed successfully. However when I go to Control Panel > Output cache I get this error:

    URL:
    http://mydomain.com/swete-admin/index.php?-action=manage_output_cache&-table=websites&website_id=428&-cursor=0&-skip=0&-limit=30&-mode=list

    PAGE ERROR:
    Fatal error: Uncaught exception 'Exception' with message 'Table 'myhostgatoraccount_SWeTE.__output_cache' doesn't exist' in /home/myhostgatoraccount/public_html/mydomain.com/swete-admin/xataface/actions/manage_output_cache.php:24 Stack trace: #0 /home/myhostgatoraccount/public_html/mydomain.com/swete-admin/xataface/Dataface/Application.php(2324): dataface_actions_manage_output_cache->handle(Array) #1 /home/myhostgatoraccount/public_html/mydomain.com/swete-admin/xataface/Dataface/Application.php(2409): Dataface_Application->handleRequest() #2 /home/myhostgatoraccount/public_html/mydomain.com/swete-admin/index.php(44): Dataface_Application->display() #3 {main} thrown in /home/myhostgatoraccount/public_html/mydomain.com/swete-admin/xataface/actions/manage_output_cache.php on line 24

    I also noticed that when I click on my french version of the website I wish to translate (as per the installation guide) I get this:

    URL:
    http://mydomain.com/french_website/

    PAGE ERROR:
    Fatal error: Call to undefined function apache_request_headers() in /home/myhostgatoraccount/public_html/mydomain.com/swete-admin/inc/LiveCache.php on line 480

    Please help me figure out how to fix this!

    Pavel

     
    • Steve Hannah
      Steve Hannah
      2012-07-11

      Hi Pavel,

      Thanks for posting this. We haven't tried it out on FastCGI yet (that is what the apache_request_headers() error is related to. I'm going to try setting up a copy on Dreamhost (should be similar to HostGator) and see if we can iron out the kinks.

      The first error you mentioned (output cache) is nothing to worry about. The application doesn't use the output cache feature. We'll hide this link in the next release.

      Steve

       
  • Pavel Reyes
    Pavel Reyes
    2012-07-11

    Thank you Steve,

    Looking forward to also help. If there are any further tests that you'd like me to try out in this shared-hosting environment with Hostgator go ahead and let me know and I'll be happy to report back results.

    Pavel

     
    • Steve Hannah
      Steve Hannah
      2012-07-11

      Thanks Pavel. I'm hoping to get everything running on Dreamhost today (i'm just waiting for some DNS propagation delay to set up a test site). I'll post the changes. I would expect that once it is working on Dreamhost, it should also work on Hostgator - but any testing and bug reports are welcome.

      -Steve

       
  • Steve Hannah
    Steve Hannah
    2012-07-11

    This issue is now fixed in SVN. It will be included with the 0.2.1 release. You can fix it in your copy by replacing your swete-admin/index.php file with the one found at
    http://weblite.ca/svn/swete-swerver/branches/0.2.x/swete-admin/index.php

    I have tested this on Dreamhost and it works ok.

    The next release 0.2.1 will be out on Friday. It will include some other bug fixes as well for improved support for handling non-compliant HTML and XHTML - and a few other fixes.

    Please let me know how it goes.

    -Steve

     
  • Pavel Reyes
    Pavel Reyes
    2012-07-12

    Hi Steve, it worked like a charm.
    Thanks,
    Pavel

     
  • Juddi
    Juddi
    2014-04-01

    Hi
    working on XAMPP in windows here and as I follow all the installation steps I receive that message at the end:

    Fatal error: Uncaught exception 'Exception' with message 'Duplicate column name 'auto_approve'' in C:\xampp\htdocs\swete-server-0.2.3\swete-admin\modules\tm\installer.php:463 Stack trace: #0 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\modules\tm\installer.php(456): modules_tm_installer::query('ALTER TABLE `...') #1 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\modules\tm\installer.php(387): modules_tm_installer::query(Array) #2 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\xataface\Dataface\ModuleTool.php(114): modules_tm_installer->update_4() #3 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\xataface\Dataface\ModuleTool.php(235): Dataface_ModuleTool->updateModule('modules_tm', 'modules/tm/tm.p...') #4 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\xataface\Dataface\Application.php(2079): Dataface_ModuleTool->loadModule('modules_tm') #5 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\xataface\Dataface\Application.php(2441): Dataface_Application->handleRequest(false) #6 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\ in C:\xampp\htdocs\swete-server-0.2.3\swete-admin\modules\tm\installer.php on line 463

    Please help run that successfully!
    juddi

     
  • Juddi
    Juddi
    2014-04-01

    Hi
    working on XAMPP in windows here and as I follow all the installation steps I receive that message at the end:

    Fatal error: Uncaught exception 'Exception' with message 'Duplicate column name 'auto_approve'' in C:\xampp\htdocs\swete-server-0.2.3\swete-admin\modules\tm\installer.php:463 Stack trace: #0 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\modules\tm\installer.php(456): modules_tm_installer::query('ALTER TABLE `...') #1 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\modules\tm\installer.php(387): modules_tm_installer::query(Array) #2 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\xataface\Dataface\ModuleTool.php(114): modules_tm_installer->update_4() #3 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\xataface\Dataface\ModuleTool.php(235): Dataface_ModuleTool->updateModule('modules_tm', 'modules/tm/tm.p...') #4 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\xataface\Dataface\Application.php(2079): Dataface_ModuleTool->loadModule('modules_tm') #5 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\xataface\Dataface\Application.php(2441): Dataface_Application->handleRequest(false) #6 C:\xampp\htdocs\swete-server-0.2.3\swete-admin\ in C:\xampp\htdocs\swete-server-0.2.3\swete-admin\modules\tm\installer.php on line 463

    Please help run that successfully!
    juddi

     
    • Steve Hannah
      Steve Hannah
      2014-04-01

      Try using the version on Github. The one on the website is a little out of date.
      https://github.com/shannah/swete

       
  • Juddi
    Juddi
    2014-04-02

    thank you! Now, I installed the new version but I still receive error message :

    Warning: require_once(xataface/public-api.php): failed to open stream: No such file or directory in C:\xampp\htdocs\swete-master\swete-admin\index.php on line 93

    Fatal error: require_once(): Failed opening required 'xataface/public-api.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\swete-master\swete-admin\index.php on line 93

    could it be because I'm using local server on my comp?

    thanks again!

     
  • Steve Hannah
    Steve Hannah
    2014-04-02

    When checking out of git, you need to use ant to build the sources. I have attached instructions.
    Also, I was looking at your error on installing swete 0.2.3 and it looks like you must have had a partial install prior to this install. If you just deleted the database and created a new one fresh, then loaded it up, it should just work. It could be that you hit refresh while it was in the middle of the initial load, causing it to run an install twice.

     
  • Juddi
    Juddi
    2014-04-04

     
    Last edit: Juddi 2014-04-08
  • Juddi
    Juddi
    2014-04-08

    hah huu issue resolved.

    amazing program! definitely worth the fuss! thanks again

     
    Last edit: Juddi 2014-04-08
  • Steve Hannah
    Steve Hannah
    2014-04-09

    Great! Glad to hear you got it working.

    Steve