#5 Postgresql does not work with latest version 1.03

open
nobody
None
5
2007-11-24
2007-10-26
David Byrne
No

I used PostgreSQL in the past with svnmanager version 0.38. I saw that there was an upgrade and downloaded it. It does not work correctly with PostgreSQL. I was able t o get it to work by manually changing the SQL it was trying to run to create the tables (dealing specifically with the autoincrement option). Also, I had to change the interface to not insert nulls in for keys. PostgreSQL will handle the autoincrement if the key is not present. After these two changes, it appears to work so far. I did not change the code for handling the SQL, I just manually executed the modified SQL.

Discussion

  • Marijn Verkerk
    Marijn Verkerk
    2007-11-24

    • labels: 729376 -->