On Thu, Mar 20, 2014 at 6:38 PM, Ahmet Emir Ercin <ahmetemiremir@gmail.com> wrote:
My Path variable is C:\Program Files (x86)\CMake 2.8;C:\Program Files (x86)\CMake 2.8\bin;C:\Program Files (x86)\Bazaar;C:\Qt\4.8.0;C:\Qt\4.8.0\bin;C:\MinGW64\bin;C:\Qt\4.8.0\lib;C:\MinGW64\lib;
I downloaded ready to use MingW64 from stellarium's build instructions page.
I'm using Cmake 2.8.0
I want to build 12.4.0 which I download sources from http://sourceforge.net/projects/stellarium/files/Stellarium-sources/0.12.4/
Also Ms VS2010 is installed on my computer.Errors are about "undeclared references to __imp__..." and  src/CmakeFiles/stelMain.dir

If you want to know any other specific conf and error dump I can also send them.Please let me know

Why do you use MinGW64?  Are you trying to build a 64-bit version of Stellarium? If you have a 64-bit system, a 64-bit version of Stellarium is not necessary - Windows will run the regular 32-bit version without any problem.

Using a 64-bit compiler may be the reason for your problem, as pre-built Qt 4.8 packages for MinGW seem to support only 32-bit systems. See the documentation here:
http://qt-project.org/doc/qt-4.8/supported-platforms.html

There are two pages on building Stellarium 0.12 with MinGW on the wiki, one for 32- and one for 64-bit versions. Which one did you use?

(Again, a remainder to the other mailing list participants: this has been sent from a user that does not subscribe to the mailing list. When replying, please use the "Reply to all" function, otherwise your e-mail will be sent only to the list.)

Regards,
Bogdan Marinov