My Path variable is C:\Program Files (x86)\CMake 2.8;C:\Program Files (x86)\CMake 2.8\bin;C:\Program Files (x86)\Bazaar;C:\Qt\4.8.0;C:\Qt\4.8.0\bin;C:\MinGW64\bin;C:\Qt\4.8.0\lib;C:\MinGW64\lib;
I downlaoded Qt 4.8.0 from http://download.qt-project.org/archive/qt/4.8/
I downloaded ready to use MingW64 from stellarium's build instructions page.
I'm using Cmake 2.8.0
I want to build 12.4.0 which I download sources from http://sourceforge.net/projects/stellarium/files/Stellarium-sources/0.12.4/
Also Ms VS2010 is installed on my computer.Errors are about "undeclared references to __imp__..." and  src/CmakeFiles/stelMain.dir

If you want to know any other specific conf and error dump I can also send them.Please let me know

Thanks for your help.
Best Regards.


On Thu, Mar 20, 2014 at 6:08 PM, Bogdan Marinov <daggerstab@gmail.com> wrote:
On Thu, Mar 20, 2014 at 5:32 PM, Ahmet Emir Ercin <ahmetemiremir@gmail.com> wrote:
Hi,
I want to build stellarium (0.12.4) with MSYS ,It's going well untill 7% and suddenly giving thounds of errors and exits.Example of error text is:

Cmakefiles/stelMain.dir/object.a<StelLocationMgr.cpp.obj>:StelLocationMgr.cpp:(.text+0x09c2):undefined reference to '__imp__ZN5QFileC1ERK7qStrigng'.All of them are like this.

Is there anyone who can help me?

It looks like a linker error. It's likely that the linker can't find the Qt libraries for some reason. Have you added the location of the Qt installation to your PATH variable correctly?

Without any other information about the specifics of your setup it's very hard to tell what went wrong.

(A note to mailing list participants: this has been sent from a user that does not subscribe to the mailing list. When replying, make sure that their email address is in the "To" or "Cc" field, otherwise they won't be able to see your reply.)

Regards,
Bogdan Marinov