Hi Alex
I have basically been doing that
My paths are /opt/Qt5.1.1/5.1.1/gcc/bin
and /opt/Qt5.1.1/5.1.1/gcc/lib/cmake
I haven't tried CMAKE_PREFIX_PATH =
or LD_PRLOAD
yet
so I had better try again
However I used the 32 bit binary pack because I an not sure whether my Vmware is 64 bit
 
Barry
 

Date: Fri, 27 Sep 2013 10:59:18 +0700
From: alex.v.wolf@gmail.com
To: stellarium-pubdevel@lists.sourceforge.net
Subject: Re: [Stellarium-pubdevel] Shortcut manager refactorization

Hi Barry,

2013/9/27 Barry Gerdes <barrygastro@hotmail.com>
I would like to start building in linux again but am having trouble installing Qt5 in my Win 8 virtual drive version.
What files are you using. Did you build Qt 5 from source or use the linux version from qt-project.org

I use binary packages from qt-project.org
 
I also tried this on a virtual  Linux under Win 7 where Qt 5.1.1 did install from the linux install file but Stellarium cannot find the Qt5 files.

If you install it to /opt then you need update $PATH before run cmake like this:
export PATH=/opt/Qt5/5.1.1/gcc_64/bin:$PATH

Or you can run export CMAKE_PREFIX_PATH=/opt/Qt5/5.1.1/gcc_64/lib/cmake and run cmake.

Plus you need use LD_PRELOAD for binary package.

For example I use /opt/Qt5 for Qt 5.1.1 and /opt/stellarium for Stellarium packages. Inside /opt/stellarium/bin I have run.sh file, which start Stellarium/Qt5: http://astro.uni-altai.ru/~aw/stellarium/run.sh.txt


--
With best regards, Alexander

------------------------------------------------------------------------------ October Webinars: Code for Performance Free Intel webinars can help you accelerate application performance. Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from the latest Intel processors and coprocessors. See abstracts and register > http://pubads.g.doubleclick.net/gampad/clk?id=60133471&iu=/4140/ostg.clktrk
_______________________________________________ Stellarium-pubdevel mailing list Stellarium-pubdevel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/stellarium-pubdevel