Those documents are out-of-date.  You do not want Subversion.  You want Bazaar.

I'll see about getting them updated.

On Thu, May 12, 2011 at 7:48 AM, rusirius@qcontinuum.plus.com <rusirius@qcontinuum.plus.com> wrote:
I've been following the instructions on the Compilation on Macosx page
and I have installed Xcode, cmake and Qt and macports but I have hit a
couple of snags:

Firstly, when I run:

$ sudo port install subversion

I get:

Warning: No index(es) found! Have you synced your source indexes?
Error: Port subversion not found.

I tried doing a:

$sudo port -d sync

But I get another error:

Error: Synchronisation of the local ports tree failed doing rsync
DEBUG: Synchronisation of 1 source(s) failed
  while executing
"mportsync [array get global_options]"

Secondly, I thought I could ignore the subverion download for now and I
proceeded to compile Libiconv. However,  when I try to configure as per
the page the first of the dependencies, i.e. Libiconv, I get:

configure: error: in `/Users/johnc/Src/libiconv-1.13.1':
configure: error: C compiler cannot create executables

Since the whole point of a compiler is to produce executables (and
libraries) this doesn't make much sense to me and I'm not sure how to
proceed. I installed Xcode from the Snow Leopard CD, but the CD is
version 10.6.3 but my system has been upgraded to version 10.6.6.  Also,
when I finished installing Xcode, nothing was placed in Applications or
on the Dock although there is an Xcode application in
/Developer/Applications. I've tried leaving out the -arch ppc bit as
this is an Intel machine but this makes no difference either.

How do I fix a compiler that won't compile executables?



------------------------------------------------------------------------------
Achieve unprecedented app performance and reliability
What every C/C++ and Fortran developer should know.
Learn how Intel has extended the reach of its next-generation tools
to help boost performance applications - inlcuding clusters.
http://p.sf.net/sfu/intel-dev2devmay
_______________________________________________
Stellarium-pubdevel mailing list
Stellarium-pubdevel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/stellarium-pubdevel