How very odd!  It's things like that that will drive you crazy!



On Thu, Jan 20, 2011 at 7:15 AM, rusirius@qcontinuum.plus.com <rusirius@qcontinuum.plus.com> wrote:
Just thought I'd feed back the fact that I've compiled and ran the Example Dialog plugin on a native Windows XP SP3 system and it ran Ok. I then tried running the the binary I'd compiled on the Virtual XP system and it gave me the same problem. It would appear then that this is something to do with compiling in Virtual XP Mode on a Windows 7 Pro system.



On 19/01/2011 13:40, rusirius wrote:

I built the example 'out of the box' as it were and the StelDialog class is already called StelDialogExampleDialog here, so yes, it has been re-named from StelDialog to a custom name. I downloaded the package file by file from here, taking care to ensure everything was in the same directory structure (i.e. /, /src and /src/gui).
http://stellarium.svn.sourceforge.net/viewvc/stellarium/trunk/extmodules/ExampleDialog/
My XP virtual machine is at SP3 as well but I downloaded the Qt SDK which appears to contain version 4.7.0 of the Qt libraries. I have therefore upgraded Qt to Qt4.7.1 and recompiled both Stellarium and the Example Plugin. Just to be sure, I also cleared the CMake cache and downloaded the plugin GNU tarball and did a freash build. Unfortunately I still got the same problem.

I also updated the Stellarium source in Bazar (now at version 4867), cleared the CMake cache and re-compilled again but it made no difference.

I can also add that on Windows I have gettext 0.14.4, libiconv 1.9.2-1 and zlib 1.2.3.

To me this seems to have ruled out:

- Qt library version
- Example Plugin version
- Stellarium version

The only common item here appears to be Windows. I will go through the compile steps again on a real XP installation to rule out some odd behaviour due to running in a VM.



On 18/01/2011 13:30, Reaves, Timothy wrote:
For your StelDialog, have you renamed it something like MyPluginStelDialog, and insured your dialog subclasses this?

On 18/01/2011 17:52, Bogdan Marinov wrote:
On my Windows XP SP3, with Qt 4.7.1, I built ExampleDialog straight
out of the repository and it worked without a problem. I don't know
why it causes a crash on your system.

Bogdan

------------------------------------------------------------------------------ Protect Your Site and Customers from Malware Attacks Learn about various malware tactics and how to avoid them. Understand malware threats, the impact they can have on your business, and how you can protect your company and customers by using code signing. http://p.sf.net/sfu/oracle-sfdevnl
_______________________________________________ Stellarium-pubdevel mailing list Stellarium-pubdevel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/stellarium-pubdevel


------------------------------------------------------------------------------
Protect Your Site and Customers from Malware Attacks
Learn about various malware tactics and how to avoid them. Understand
malware threats, the impact they can have on your business, and how you
can protect your company and customers by using code signing.
http://p.sf.net/sfu/oracle-sfdevnl
_______________________________________________
Stellarium-pubdevel mailing list
Stellarium-pubdevel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/stellarium-pubdevel