Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Problems running the telescope control plugin

Feedback
2013-04-09
2013-04-25
  • Dieter Koenig
    Dieter Koenig
    2013-04-09

    Has anybody hints or solutions for my problem using a Meade LX90 GPS controlled by Stellarium's Telescope AddOn.

    My configuration:
    - Meade LX90 GPS with Autostar #497
    - Profilic's pl-2303 USB-to-Serial (Driver 3.4.48.272) to connect telescope and notepad.
    - Windows 7
    - Stellarium 0.12.0
    Actions (chronol. order):
    1. Telescope setup and alignment completed
    2. USB-to-Serial cable connected to my notepad
    3. Stellarium started and showing: Telescope connected b u t there is no crosshair to be seen
    4. Selecting any asoronomical object
    5. CNTR+1 (or "Move telescope to"-window) to go to the selected object b u t nothing happened!
    The simulation (telescope #2) works fine!
    For more informations see the appending excerps from the log files.

    log.txt

    2013-04-03T11:12:48
    Windows 7
    Compiled using MinGW GCC 4.6.2
    Qt runtime version: 4.8.4
    Qt compilation version: 4.8.4
    Addressing mode: 32-bit
    Total memory: 4025 MB (unreliable)
    Total virtual memory: 2047 MB (unreliable)
    Physical memory in use: 29%
    Processor speed: 2294 MHz
    Processor name: Pentium(R) Dual-Core CPU T4500 @ 2.30GHz
    Processor speed: 2294 MHz
    Processor name: Pentium(R) Dual-Core CPU T4500 @ 2.30GHz
    C:\Program Files (x86)\Stellarium\stellarium.exe


    [ This is Stellarium 0.12.0 - http://www.stellarium.org ]
    [ Copyright (C) 2000-2013 Fabien Chereau et al ]


    . . . . . . . . . .

    Loaded plugin "TelescopeControl" .
    TelescopeControl: No telescope server directory has been found.
    TelescopeControl: Only embedded telescope servers are available.
    Creating telescope "LX 90 GPS:TelescopeServerLx200:J2000:COM4:500000" ; name/type/equinox/params: "LX 90 GPS" "TelescopeServerLx200" J2000 "COM4:500000"
    TelescopeClientDirectLx200 paramaters: port, time_delay: "COM4" 500000
    TelescopeControl: Loaded successfully 2 telescopes.
    . . . . . . . . . .

    log_TelescopeServer1.txt
    ========================
    15798, 09:12:49.756337Z: Lx200Connection::sendCommand(Lx200CommandGetRa)
    15798, 09:12:49.756337Z: Lx200Connection::writeFrontCommandToBuffer(Lx200CommandGetRa): queued
    15798, 09:12:49.756337Z: Lx200Connection::sendCommand(Lx200CommandGetDec)
    15798, 09:12:49.757337Z: Connection::performWriting: writeNonblocking(5) returned 5; #:GR#
    15798, 09:12:54.781624Z: Lx200Connection::resetCommunication
    15798, 09:12:54.827627Z: Lx200Connection::sendCommand(Lx200CommandGetRa)
    15798, 09:12:54.827627Z: Lx200Connection::sendCommand(Lx200CommandGetDec)
    15798, 09:13:04.805198Z: Lx200Connection::writeFrontCommandToBuffer(Lx200CommandGetRa): queued
    15798, 09:13:04.806198Z: Connection::performWriting: writeNonblocking(5) returned 5; #:GR#
    15798, 09:13:09.844486Z: Lx200Connection::resetCommunication
    15798, 09:13:09.896489Z: Lx200Connection::sendCommand(Lx200CommandGetRa)
    15798, 09:13:09.896489Z: Lx200Connection::sendCommand(Lx200CommandGetDec)
    15798, 09:13:19.891060Z: Lx200Connection::writeFrontCommandToBuffer(Lx200CommandGetRa): queued
    15798, 09:13:19.892061Z: Connection::performWriting: writeNonblocking(5) returned 5; #:GR#
    15798, 09:13:24.893347Z: Lx200Connection::resetCommunication
    15798, 09:13:24.944349Z: Lx200Connection::sendCommand(Lx200CommandGetRa)
    15798, 09:13:24.944349Z: Lx200Connection::sendCommand(Lx200CommandGetDec)
    15798, 09:13:34.920920Z: Lx200Connection::writeFrontCommandToBuffer(Lx200CommandGetRa): queued
    15798, 09:13:34.921920Z: Connection::performWriting: writeNonblocking(5) returned 5; #:GR#
    15798, 09:13:39.924206Z: Lx200Connection::resetCommunication
    15798, 09:13:39.976209Z: Lx200Connection::sendCommand(Lx200CommandGetRa)
    15798, 09:13:39.976209Z: Lx200Connection::sendCommand(Lx200CommandGetDec)
    15798, 09:13:49.253740Z: Lx200Connection::sendCommand(Lx200CommandStopSlew)
    15798, 09:13:49.253740Z: Lx200Connection::sendCommand(Lx200CommandSetSelectedRa(23:11:17))
    15798, 09:13:49.253740Z: Lx200Connection::sendCommand(Lx200CommandSetSelectedDec(-7:17:40))
    15798, 09:13:49.253740Z: Lx200Connection::sendCommand(Lx200CommandGotoSelected)
    15798, 09:13:49.953780Z: Lx200Connection::writeFrontCommandToBuffer(Lx200CommandGetRa): queued
    15798, 09:13:49.954780Z: Connection::performWriting: writeNonblocking(5) returned 5; #:GR#
    15798, 09:13:54.996068Z: Lx200Connection::resetCommunication
    15798, 09:13:55.047071Z: Lx200Connection::sendCommand(Lx200CommandGetRa)
    15798, 09:13:55.047071Z: Lx200Connection::sendCommand(Lx200CommandGetDec)

     
  • barrykgerdes
    barrykgerdes
    2013-04-09

    I nolonger have 0.12.0 loaded and there is no problem with my 0.12.1 build

    It may be that the cross hairs are just invisible.
    Firstly load a dummy telescope as telescope 1 then see if the crosshairs work.
    If still not visible.
    Did it work with a previous version of Stellarium

    Barry

     
  • Dieter Koenig
    Dieter Koenig
    2013-04-11

    I tried it successfully (incl visible cross hair) with a dummy telescope.
    The control plugin indead works with my LX90GPS, with the above mentchend connecting cable and an older version of Stellarium, but unfortunatelly I can't say which it was. But what I know is, it runs under Windows XP.

    thanks, Dieter

     

  • Anonymous
    2013-04-18

    It may sound a little crazy, but if you can change USB ports on your computer and reset COM port in program, it may just work. A laptop I had did the same thing. Changing COM port solved the issue. Good luck

     
  • Dieter Koenig
    Dieter Koenig
    2013-04-23

    Hello Anonymous,
    thanks for your hints. I tried it! I changed the USB ports at my laptop. Indead the COM port changed from COM4 to COM5.
    But unfortunately there was no difference. Still all seems to work fine, but again there was no crosshair und no reaction at the telescope when pressing CNTRL+1.

    As an alternave to Stellarium I also tried to control my telescope via the AutoStarCntrl program out of Meade's Autostar suite.
    It also works fine until the point where I is connected to the telescopes autostar. It says "AutoStaR Menu" and that's it! Again no reaction when pressing the approprate keys to move the telescope and no error message or comment!

    Something wrong with my telescope? But the native control via the Autostar box works fine!

     
  • Bogdan Marinov
    Bogdan Marinov
    2013-04-23

    But the native control via the Autostar box works fine!

    This leads me to a possible cause of your problem.

    How is the PC-to-telescope cable connected to the telescope? Directly to the mount or to the hand controller?

    As far as I know, it should be to the hand controller.

     
  • Dieter Koenig
    Dieter Koenig
    2013-04-25

    To the AUX port of the telescope!

    And that is w r o n g !!!!!! I'm so stupid, sorry.

    Indead it has to be connected directly to the the hand controller!
    I just tried it and it works completely fine.

    Thank you very much, Bogdan

     


Anonymous


Cancel   Add attachments