Compilation errors with gcc 4.1.0

Feedback
2006-04-14
2012-10-09
  • Compilation of stellarium with gcc 4.1.0 results in some (trivial) errors, due to a more strict syntax check in the new version of gcc c++. For instance:
    projector.h:78: error: extra qualification ‘Projector::’ on member ‘draw_viewport_shape’

    Removing the extra qualifications like "Projector::" solves this issue. See http://womble.decadentplace.org.uk/c++/syntax-errors.html for a very clear description of this issue.
    In stellarium, four sources are involved: observator.h, projector.h, stel_command_interface.h and stel_ui.h.

     


Anonymous


Cancel   Add attachments