configure ipv6 protocol support in STAF.cfg

Help
shoyab
2013-01-10
2013-06-12
  • shoyab
    shoyab
    2013-01-10

    Hello Everyone,

    When I installing STAF, I used all default values so now I can't able to work on ipv6 protocol. Can I configure STAF.cfg file such that STAF can support ipv6 also and if yes how to configure that.


    Thanks

     
  • Sharon Lucas
    Sharon Lucas
    2013-01-10

    Yes, you can edit your STAF.cfg file and update the PROTOCOL option specified for your network inferfaces.  This is talked about in section "4.3 Network Interfaces" in the STAF User's Guide at http://staf.sourceforge.net/current/STAFUG.htm#HDRNETWORKCFG.  Any changes to the STAF.cfg file do not take effed until STAFProc is shutdown and restarted.

    The STAFTCP connection provider supports the PROTOCOL option as described here:

    PROTOCOL=<IPv4 | IPv6 | IPv4_IPv6> specifies the communication protocol that this connection provider uses. The possible values are IPv4, IPv6, or IPv4_IPv6. When this option is absent, the default is IPv4_IPv6 which indicates to use both IPv4 and IPv6 protocols. This option is only valid for IPv6 enabled versions of STAF.

    For example:

    INTERFACE ssl    LIBRARY STAFTCP OPTION SECURE=Yes OPTION PORT=6550 OPTION PROTOCOL=IPv4_IPv6
    INTERFACE tcp    LIBRARY STAFTCP OPTION SECURE=No  OPTION PORT=6500 OPTION PROTOCOL=IPv4_IPv6

    You can display how the STAF network interfaces are currently configured by submitting the following command:

    STAF local MISC LIST INTERFACES

     
  • shoyab
    shoyab
    2013-01-11

    This is what I configured:

    interface ssl library STAFTCP option Secure=Yes option Port=6550 option Protocol=IPv4_IPv6
    interface tcp library STAFTCP option Secure=No option Port=6500 option Protocol=IPv4_IPv6

    This is error I am getting:
    Error on Interface definition line:

    interface ssl library STAFTCP option Secure=Yes option Port=6550 option Protocol=IPv4_IPv6

    Error code: 47
    Reason    : Error creating interface.  STAFConnectionProviderConstruct: PROTOCOL must be set to IPv4

    Error in configuration file: /usr/local/staf/bin/STAF.cfg