Floating point exception starting STAFProc

Help
JeffC
2013-02-06
2013-06-12
  • JeffC
    JeffC
    2013-02-06

    I have two machine running SuSE v10.2 where one is 32-bit and the other is 64-bit.  I have two similar machines running SuSE v11.2.  I have them all setup in a very similar manner.

    I'm trying to get STAF v3.4.12 to run on all four boxes.  I'm using /etc/profile to setup the user environments.  And I'm using /etc/rc.d/rc to start  STAFProc.  The of the SuSE v11.2 boxes are working great.

    When I copy the same executables to the SuSE v10.2 boxes and edit the same files in a similar manner, I can not get STAFProc to even begin to run.  It throws a 'floating point exception' immediately.  This is happening on both the 32-bit and the 64-bit versions of SuSE v10.2.

    I've had no trouble getting earlier versions of STAF to run on SuSE v10 and SuSE v11.

    Any suggestions?

     
  • Sharon Lucas
    Sharon Lucas
    2013-02-06

    The recommended way of starting STAFProc at system reboot on SLES 10 and 11 systems is talked about in the STAF V3 Installation Guide accessible via the STAF Documentation web page at http://staf.sourceforge.net/docs.php.  See section "11.1 Unix", under "Linux", and then under "SLES 10 and 11".

    I don't know of anything that has changed in STAF V3.4.12 that should cause any issues.

     
  • JeffC
    JeffC
    2013-02-06

    Well, my problem is that I can't get it to start at all, even from a bash shell running as root.  I assume that I need to get past this error when invoked from bash before I can expect 'auto-run at system reboot' to work.

     
  • JeffC
    JeffC
    2013-02-06

    I downloaded and ran the full installer (the bin version) on these SuSE v10.2 boxes.  I'm not trying to auto-start STAFProc.  When I attempt to run STAFProc from a bash shell as root, I still get the floating point exception.

    BTW, I'm using the IPv6 and Perl 5.14 libraries.

    I've been using STAF 3.3.4 for ages, so I'll give it a whirl on the same machines.

     
  • JeffC
    JeffC
    2013-02-06

    Interesting.  When I reverted back to STAF v3.3.4, everything works great.  I'm using exactly the same /etc/profile and /etc/rc.d/rc contents.  And it includes using the IPv6 and Perl v5.10 libraries.  All that changed was the STAF executables.

    Note that I'm only using 32-bit STAF on both SuSE systems, 32-bit and 64-bit, not that this has ever caused a problem in the past.

    I want to upgrade to a later version of STAF because we're moving to Perl 5.16 and want a version of STAF that recognizes Windows 8 and Windows 2012.

     
  • Sharon Lucas
    Sharon Lucas
    2013-02-07

    Many changes to the Linux 32-bit (i386) and Linux 64-bit (x86_64 / AMD64) systems used to build the binaries for the STAF Linux installers have occurred since STAF 3.3.4 (which was released in June 2009).  The Linux i386 and AMD64 STAF build systems have been upgraded to RHEL 5.8 (as older versions had readed End of Life).  So, it's possible that the STAF binaries for Linux i386 and AMD64 are no longer compatible with your old SLES 10.2 system.  SLES 10.2 reached end of life on 05-31-2005.  Later SLES 10 releases, e.g. 10.4, have not reached End of Life yet.  In fact, the STAF 3.4.12 Linux PPC64 binaries are built on a SLES 10.4 PPC system.

    So, you may want to upgrade your SLES 10.2 system to a supported version (e.g. 10.4) and then perhaps it will be compatible.  Or, you could try building STAF binaries yourself on your SLES 10.2 machine following the instructions in the STAF V3 Developer's Guide at http://staf.sourceforge.net/current/stafdg.html.  Then try running STAF using the version of STAF that you built.  Hopefully, that will work.

     
  • Sharon Lucas
    Sharon Lucas
    2013-02-07

    The STAF History file contains some information about when STAF Linux build machines were upgraded (see http://staf.sourceforge.net/history.php).

     
  • JeffC
    JeffC
    2013-02-07

    Sorry, I mistyped.  I should have said 10.3.  I'm running the latest shipping version of Novell's Enterprise SuSE v10.3 (vs. OpenSuSE.)  There is no 10.4 on the Novell/SuSE website, at least not that I can see with our Novell technical partnership.

    But you make good points.

    I integrated STAF 3.2.3 into the automation framework that drives all of the testing for our product.  We began using STAF 3.3.4 when we added Mac OSX machines to our benches.  Very recently, we decided to update things so our plumbing would better support Windows 8 and 2012.

    The platforms that QA has to test against are decided by engineering and product management.  We always test with the latest SP of each of the two latest major SuSE/RedHat releases, in this case SuSE 10.3 and 11.2 or RedHat 5.9 and 6.3.

    Large automation frameworks thrive on consistency, so I was hoping to upgrade all of our test machines so they're running the same versions of pretty much everything, like Apache, Java, Ant, JBoss, Perl and STAF.  However it looks like we'll need to make an exception for the STAF version that we place on our SuSE v10.3 machines.

    Thanks for your help with this.