Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

email service Must issue a STARTTLS ...

Sam Kim
2012-03-13
2013-06-12
  • Sam Kim
    Sam Kim
    2012-03-13

    Hi, sorry
    its me again,

    i do have different errors while sending an email, one is

    "…. Must issue a STARTTLS command first."

    do i have to install Postfix to be able to run email service ?
    i don think so, because there is no need of service, i could just make stax job, which is sending emails with Postfix.

    i guess, i m just blind and or to new to this

    thank you for help
    sam

     
  • Sam Kim
    Sam Kim
    2012-03-13

    "Error: authentication failed: generic failure"

    another one,

    authpassword seems to be interesting !!@ mypasswort @!!  returns rc 7

    and other stuf is not working  only exit@ mypassword xit  ist working with !!@ my password, but with the UPPER error message

    :S no luck here

     
  • Sharon Lucas
    Sharon Lucas
    2012-03-14

    You don't need to isntall Postfix to use the STAF Email service.

    You should not have spaces between the privacy delimiters and your password.  For example:

    STAF local EMAIL SEND TO email@gmail.com message "Test XYZ completed successfully"
    SUBJECT "Test XYX: Success" AUTHUSER "email@gmail.com" AUTHPASSWORD "!!@password!!"

    In regards to error message ""530 5.7.0 Must issue a STARTTLS command first.", what port did you have configured when registering the Email service?  If you specified port 587, according to http://support.google.com/mail/bin/answer.py?hl=en&answer=13287, that is the port for TLS/STARTTLS.  Instead of using that port, did you try the port for SSL which that link says is 465?

     
  • Sharon Lucas
    Sharon Lucas
    2012-03-14

    I had a typo in my example, the ending privacy delimiter should have been !!@.  For example:

    STAF local EMAIL SEND TO email@gmail.com message "Test XYZ completed successfully"
    SUBJECT "Test XYX: Success" AUTHUSER "email@gmail.com" AUTHPASSWORD "!!@password!!@"

     
  • Sam Kim
    Sam Kim
    2012-03-16

    it just wont wotk …

    now it says nothing, just waiting :S