Gap4 editor grey vs. white sequences

  • Hi, I am using pregap4 and gap4 to automatically detect mutations.  In the new version of mutscan, when the gap4 database is opened, some sequences are white and some are grey.  The grey sequences are the only ones that give mutation data when "report mutations" is selected.  Why are some sequences white and how can they be forced to be included when scanning for mutations?

    Thanks, Bryan Smith, Dept. of Biochem., Univ. of Wisconsin-Madison

    • James Bonfield
      James Bonfield

      The grey tag is of type MCOV. It indicates the region over which the sequence was aligned to the reference trace and considered to be valid. The purpose is to demonstrate regions of a trace which will not have been checked for mutations.

      There's two reasons why an MCOV tag will not be generated.

      1) The sequence alignment simply failed. This is probably because the two sequences diverge at some point (maybe due to poor quality data that hasn't been clipped?). Pregap4 logs these as errors with the text "Insufficient sequence overlap to compute trace alignment for ...".

      Ideally mutscan should do a local alignment here instead of a global alignment so it can take the portion of a sequence which matches and ignore the rest, but it doesn't.

      2) Having got the sequences aligned, mutscan then aligns the trace data directly so that overcalls and undercalls do not generate spurious mutations unless backed up with real trace data.  Sometimes though the trace alignment isn't great which is typically shown up by lots of differences being detected. The pregap4 parameter to adjust this is "Trace alignment failure threshold (in mutations)" in the Mutation Scanner module. Pregap4 reports these failures as "Trace alignment failed for ...".