Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo


Step by step installation procedure of Staden on Mac OX needed

  • Malte Horvat
    Malte Horvat


    I have downloaded the staden package "staden-2.0.0b9-macosx.dmg" on my mac Version 10.8.5 with X11 and macports ( but no additional stuff installed for macports). When opening the download directly, the computer creates a virtual disk imagine. So I copied the whole staden folder to the Applications in the finder and then deleted the virtual disc image.
    Pregap4 and Gap4 ( which are the programs that I will need) are opening.

    But there occurs a problem with Pregap4:

    I open 4 sequence reads, by clicking on "add files", then under "configure modules" select among others "Interactive clipping" and click on "run".
    After running it claims that the following error occurred:

    interactive_clip::run: couldn't read file "/Applications/Staden": no such file or directory

    I guess that means that the staden package is not properly installed. ( If this assumption is wrong and the problem can be solved directly without a complicated installation procedure the staden package then please tell me!)
    When searching the staden webpage I could not find any Instructions for installation of staden on Mac OX. There is also not a trace of a hint how to install this packet in the staden download folder itself, as it is usually common.

    Looking for this problem in this forum I find only discussions about specific problems, with explanations way beyond my obviously very basic computer knowledge, but no hint how to install the package.

    So could someone please provide a procedure for installation, with every single step listed, fully explained without abbreviations and with the requirements for the macport and/or X11 configurations,addons etc.?

    Many thanks in advance for your rapid replies,


    Last edit: Malte Horvat 2013-11-27
    • James Bonfield
      James Bonfield

      I have my suspicions that

      interactive_clip::run: couldn't read file "/Applications/Staden": no such file or directory

      means you have a directory called "/Applications/Staden Package" but the directory is not being properly quoted somewhere inside pregap4. If so it's a bug, but it can easily be worked around by renaming the directory to /Applications/Staden_Package instead.

      Please try this and see if it cures it. If so we need to track it down and fix it, although pregap4 isn't really supported any more so I cannot dedicate much time to it.

      Whether or not it still works with STARS I have no idea, but it's highly unlikely as STARS was a third-party extension around an old version of the Staden Package.

  • Malte Horvat
    Malte Horvat

    More news from the "Staden Pandoras box®" in my machine.

    After renaming the file Staden2.irgendwas.dmg (which lives in my application folder) in simply "staden", I did not get the above mentioned error message any more. It seems like some kind of wicked progress.

    Instead this error message occured:

    interactive_clip::run: child killed: segmentation violation

    Two questions

    1. Would it not be more consequent as well as easier comprehensible for the general public, if you would just use e.g. sanskrit swearwords as a program language for staden?
    2. Could it be the same problem as in the below mentioned quotation ( found at this page http://pubmlst.org/software/assembly/installation_of_stars_on_biolinux.pdf)

    ”Error: child killed: Segmentation violation”

    What seems to be happening is that in the /usr/local/stars-1.2a/contig-editor file
    is an event handler to close the database when the window shuts. However,
    it all happens too quickly for the database to close cleanly. Adding a 500ms
    pause solves the problem. Edit the end of the contig-editor file as below:

    close database, trap quit from editor

    foreach child [winfo children .] {
    bind $child <Destroy> {
    #500ms pause added by Keith Jolley
    after 500 {
    close_db -io $io

    Could any of you invisible knights from Kafkas Torhüter-Brigade soon guide me on the right path to mount doom, trevelling far past the five gaps and their four spinning pregaps, please?

    Last edit: Malte Horvat 2013-11-28
    • James Bonfield
      James Bonfield

      I should have read the second message too! Clearly renaming it does fix that issue and so it is indeed a filename quoting bug.

      The second problem though is clearly different. Do Gap4 and Pregap4 work for you? Ie by themselves and not when driven by STARS? If so I think this is a STARS compatibility bug and not something we can fix. (The fix you mention above is not to the Staden Package code but to a file within STARS.)

      As for the program language, I'm unsure what you mean. "segmentation violation" is a standard Unix (and MacOS X) error message and not one produced by us. The programming languages we use are C and Tcl/Tk. They aren't going to change either as there's simply too many lines of code and no strong desire to change.