Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

pregap4 and incorrect tcl version

Adam Henk
2010-11-17
2013-04-18
  • Adam Henk
    Adam Henk
    2010-11-17

    I just installed staden-2.0.0b7 on an ubuntu 10.10 system, and pregap4 doesn't seem to be working.  When I enter the "pregap4" command I get the following:

    version conflict for package "Tcl": have 8.4, need 8.5
        while executing
    "load /usr/lib/libitcl3.4.so.1 Itcl"
        ("package ifneeded" script)
        invoked from within
    "package require Itcl 3.2"
        (file "/usr/share/tcltk/iwidgets4.0.1/iwidgets.tcl" line 18)
        invoked from within
    "source /usr/share/tcltk/iwidgets4.0.1/iwidgets.tcl"
        ("package ifneeded" script)
        invoked from within
    "package require Iwidgets"
        invoked from within
    "if {!$interactive} {
        init_modules
        if { > 0} {
    verror ERR_WARN check_modules \
        "One or more modules have not been config…"
        (file "/usr/local/bin/../share/staden/tcl/pregap4/pregap4.tcl" line 108)

    I have the tcl 8.5 package on my system.
    I did the following:

    configure -with-samtools=/usr/loca/samtools-0.1.10/ -with-tcl=/usr/lib/tcl8.5/
    make clean
    make
    sudo make install

    in an attempt to fix this.  The configure seemed to work correctly, as did the make and make install, but I'm still getting the same response.  I'm not particularly adept with linux, and I'm not sure where to go from here; thanks for any help.

    Adam

     
  • James Bonfield
    James Bonfield
    2010-11-24

    I can sympathise with this, given the pain that itcl has caused me too. I wish we didn't have a dependency on it now (and it's only in a few places so it may be worth the effort to remove it).

    My experience of this is that it's caused by having a newer version of itcl installed, requiring tcl8.5. I'm not sure of the exact versions I used though, nor whether it's possible to have multiple versions installed at the same time.

    I'll try and find out what I did on the ubuntu build I tried.