Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

gap4: database full

2006-11-09
2013-04-18
  • Every time when I run gap4, the result is only about 7000 sequences entered into gap4 database(total: 25000) and it shows: database full,and *.exp write to erro faile, what can I do?

     
    • more informations:

      Thu 09 Nov 08:45:03 2006 Failed file APP3_S_054_65.g1.exp written to error file
      Thu 09 Nov 08:45:03 2006 Database full!
      Thu 09 Nov 08:45:03 2006 Failed file APP3_L_02_77.b1.exp written to error file
      Thu 09 Nov 08:45:03 2006 Database full!
      Thu 09 Nov 08:45:03 2006 Failed file APP3_S_045_11.b1.exp written to error file
      Thu 09 Nov 08:45:03 2006 Database full!
      Thu 09 Nov 08:45:03 2006 Failed file APP3_L_29_68_D09.g1.exp written to error file
      Thu 09 Nov 08:45:03 2006 Database full!
      Thu 09 Nov 08:45:03 2006 Failed file APP3_L_30_68_D09.g1.exp written to error file
      Thu 09 Nov 08:45:03 2006 Database full!
      Thu 09 Nov 08:45:03 2006 Failed file APP3_S_070_50.b1.exp written to error file
      Thu 09 Nov 08:45:03 2006 Database full!

      ============================================================
      Thu 09 Nov 11:54:37 2006: Database information
      ------------------------------------------------------------
      Database size            12286       Max reading length      30000
      No. Readings              7213       No. Contigs               785
      No. Annotations           7177       No. Templates            4102
      No. Clones                   1       No. Vectors                 1
      Total contig length    1839214       Average length           2342.9
      Total characters in readings                               5493530
      Average reading characters per consensus character               2.99
      Average used length of reading                                 761.62
      Current maximum consensus length is 3808853

       
    • deKesi
      deKesi
      2006-11-09

      Hello,

      by default a new database has a capacity to take up to 8000 reads.

      http://staden.sourceforge.net/manual/gap4_unix_146.html

      I don't now, if this is extended dynamically but you can extend it by yourself.

      1. activate "expert" view mode ("Options" -> "Configure menus")
      2. Open "Edit" -> "Doctor Database"
      3. There go to "Structures" -> "Database" and raise "maximum_db_size" to a value which fits your needs

      Maybe this could help to solve your problem.

      With best regards,

      deKesi

       
    • I have done that before and try this time again, but still have the same result(only 7213 sequences entered into database):

      Batch finished
         25262 sequences processed
          7213 sequences entered into database
           668 joins made
          1762 joins failed

       
    • more informations:

      Fri 10 Nov 16:05:30 2006 signal_handler: Program terminated unexpectedly with signal 11.
      Fri 10 Nov 16:05:30 2006 signal_handler: This is probably a bug.
      Fri 10 Nov 16:05:30 2006 signal_handler: Please report all bug reports at https://sourceforge.net/projects/staden/

       
    • James Bonfield
      James Bonfield
      2006-11-29

      The main options menu has a command (I forget the name, but it's obvious I hope) to adjust the "maxseq" and "maxdb" parameters. Alternatively you can do this when you initially start up gap4 with "gap4 -maxseq 1000000 -maxdb 50000" (for example). Note that it automatically resizes for most things, but specifically assembling in new readings using Normal Shotgun Assembly (which is rather old code) needs the database to be explicitly grown to be large enough before hand.

      Note that maxdb refers to the total number of sequences + contigs.
      Maxseq is the total consensus length, plus a certain amount per contig if you want algorithms such as find internal joins to be able to detect overlaps in the "hidden" or cutoff data.

      James

       
    • Dear James :

        Tank you very much, I have resolved the problem!

      kai

       
    • Dear James

      i have similar prob. i've tried to assemble 11 000 reads using gap4 and it shows: database full
      so I increase the database to maximum : maxdb 99999999 and max seq 99999999. But still the problem occurs. what should I do?

       
  • I have the some problem

     
  • I'll investigate. In theory changing maxdb and maxseq *should* work, although note they may not be preserved between runs of Gap4. On startup increases them to be something like 50% larger than the current DB size though so they're only necessary when adding a large amount of data to a currently small database.

     
  • James Bonfield
    James Bonfield
    2011-01-17

    Oops that was me; I didn't noticed I'd become logged out at some stage.

     
  • James Bonfield
    James Bonfield
    2011-01-17

    I just tried "gap4 -maxseq 10000000 -maxdb 100000" on the command line and it worked fine to assemble 20,000 sequences. (Well, the assembly was a bit poor - I'd recommend something else like phrap as a minimum for the assembly part and convert back to gap4 for editing.)

    It's possible there's a difference between using the command line and using the GUI, but I'm not aware of this.

    Note specifying huge values like 99999999 can introduce other problems. The reason there is a limit at all is due to the very old assembly algorithm which allocates memory of a fixed size. Specifying an arbitrarily large value to try and avoid this will cause out of memory errors.