Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

scripting problem: 'load_package' fail on osX

John Major
2005-10-06
2013-04-18
  • John Major
    John Major
    2005-10-06

    I've run staden scripts in the past on alphas, but am just now trying to run them on my osX machine, and am finding some odd problems [running either 1-4-1 and 1-5-4]

    ie:  When I try to run ./assemble4 directly
    I get a
    "%" prompt and the program does not execute

    If I replace the header stuff with a direct call to stash, or run assemble4  like "stash ./assemble4" I get the following error:
    --------------
    invalid command name "load_package"
          while executing
    "load_package gap"
    ---------------
    STADENROOT is set and
    I have sourced staden.profile, and all of my environment variables appear properly set. 
    I can run the GUI applications and "pregap4 -nowin ..." with no problems.

    TKUTILS_LIBRARY is not set, but it also does not appear to be set on my alpha where scripts have been running just fine[and this var is not set in the staden.profile anyway...]

    what am I missing?

    thanks,
    John

     
    • John Major
      John Major
      2005-10-06

      Got it-

      the problem was that STADENROOT was being set locally(?) but not globally.  the export command had a typo.

      echo $STADENROOT showed me the correct value, and all of the vars set by sourcing the staden.profile worked fine.
      but-  when I checked 'env', STADENROOT was missing...fixing the export typo solved this and now my scripts are working.