itk3.4 not available in Ubuntu 10.04

2010-06-01
2013-04-18
  • Hi all,
    I would like to install The Staden Package staden-2.0.0b6-src from Source code, and have - as far a I know - fulfilled all dependencies, but not itk3.4, which dependency when using tcl8.5 (note (3) in the readme).
    Unfortunately, iwidgets4 just has tcl8.5 dependency, so I really need itk3.4.

    Could someone please give me a link, where I can get itk3.4?

    Thanks and
    Best regards Detlef
     


    External packages used:
    curl:      via /usr/bin/curl-config
    zlib:      DIR (system)
    liblzma:   DIR
    samtools:  ***NOT FOUND***
    io_lib:    via /usr/local/bin/io_lib-config
    Tcl:       via /usr/lib/tcl8.5/tclConfig.sh
    Tk:        via /usr/lib/tk8.5/tkConfig.sh
    tklib:     /usr/share/tcltk/tklib0.5
    Iwidgets:  /usr/share/tcltk/iwidgets4.0.1
    Itcl:      /usr/share/tcltk/itcl3.4
    Itk:       /usr/share/tcltk/itk3.3

     
  • James Bonfield
    James Bonfield
    2010-06-02

    Hmm, my ubuntu 9 build appears to use iwidgets 4 with itcl3.2 and itk3.2. From dpkg:

    ii  iwidgets4   4.0.1-5
    ii  itcl3             3.2.1-5
    ii  itcl3-dev     3.2.1-5
    ii  itk3              3.2.1-5
    ii  itk3-dev      3.2.1-5
    ii  tcl8.4           8.4.19-2
    ii  tcl8.4-dev   8.4.19-2
    ii  tk8.4            8.4.19-2
    ii  tk8.4-dev    8.4.19-2

    My /etc/apt/sources.list contains nothing more than ubuntu.com locations.
    I'm not sure why you appear to have a tcl8.5 dependency for iwidgets4 either. I suspect it's due to itcl. Try installing an older version of itcl and then you can find the matching version of itk.

    On other platforms (Fedora perhaps? I forget now) I've managed to build everything using newer itcl/itk and tk8.5, so the code should work - but only if you can find the packages.