Staden on Mac OS X v10.4.6

2006-05-26
2013-04-18
  • Im running a mac with os x 10.4.6 and I downloaded and copied the files to my applications folder. however, whenever i try to open any of the programs (pregap4, gap4, etc.) the icon bounces a few times in my program bar but then just disappears...can anyone please help?

     
    • Do you have X11 installed?
      MDS

       
    • i dont think so..what is x11?

       
    • I think you need to read up a bit on the use of unix applications on OS X. Staden runs under the x-windows system and the apple version of this, X11, is an optional installation as part of OS X. It would normally be installed in Applications/Utilities. See if you can find it, or install it. I'm not sure if you also need to install the developer tools (can someone comment on this?). When you have X11 going, you should find someone who knows their way around unix to help you further.
      MDS

       
    • Hi,
      i have the same problem, too. After installing X11 it still does'nt work. I don't know what to do? Can anybody help, please??

      M.

       
    • My machine has a full installation of Xcode developer tools, and I'm not sure if you need that installed as well. In any case, what error message do you get when you start up X11, then type 'gap4' (no quotes) into the terminal window, then press return? My guess would be it will say 'command not found'. If so, then you probably need to get the right path setup for your installation, so it can find where you put the staden binary files. To see the path settings, you use the command 'env'
      MDS

       
    • for OSX
      1) install X11
      2) sudo nano /etc/X11/xinit/xinitrc
         export STADENROOT="/path/to/staden/folder"
               . $STADENROOT/staden.profile
      3) start X11 from finder
      4) type gap4 {whatever in xterm NOT IN TERMINAL}
      5) finally its usable

      you might wanna have $DISPLAY set for you when you log on thru terminal
      for that add the following to ~/.bash_profile
      export DISPLAY=":0.0"

      you must run the programs from xterm, not terminal because you need an X server running for this to work
      -Rohan