error while loading ... libseq_utils.so:

quwubin
2010-06-03
2013-04-18
  • quwubin
    quwubin
    2010-06-03

    Hi,
    I download the binary package of staden software, but when I run vector_clip command from bin/ directory, error found:

    ./vector_clip: error while loading shared libraries: libseq_utils.so: cannot open shared object file: No such file or directory

    But command extract_seq from bin/ directory running well.

    Can anyone tell me why and how to fix that?

    Thanks!

     
  • quwubin
    quwubin
    2010-06-03

    The package I download is "staden-2.0.0b6-i686.tar.gz".

     
  • James Bonfield
    James Bonfield
    2010-06-04

    The default install has some wrapper scripts for the main GUI apps (gap4, gap5, spin, pregap4, trev) which set up your environment. However if you want to call the sub-programs that these call then you'll need to set up your environment first - especially things like LD_LIBRARY_PATH.

    The easiest way to do this is to set the STADENROOT environment variable to the toplevel install and then source the share/staden/staden.profile script. Eg:

    jkb@seq1e[/tmp] export STADENROOT=/software/badger/opt/staden-2.0.0b6en-2.0.0b6
    jkb@seq1e[/tmp] . $STADENROOT/share/staden/staden.profile
    

    James

     
  • James Bonfield
    James Bonfield
    2010-06-04

    Ignore the extra "en-2.0.0b6" on the end of the first line I quoted. It's some strange paste accident. Anyway hopefully the intention is clear.