interactive clipping error

2005-02-16
2013-04-18
  • I am beginner in staden-1-5-3 for windows. I have a little problem with the assemble of sequencepairs in pregap4. When the interactive clipping module is activ, I become an error message, while the program is running:

    Error in startup script
    couldn't open "D:/Programs/Staden": no such file or directory while executing "open($argv 0" ("while body line40) invoked from within "while ($argc>=1)( set arg(string tolower (index $argv0)) if ($arg=="edits")( set e(index $argv 1) incr argc-1 set argv..." file "d:/programs staden packege/lib/trev/trev.tcl"line 1460)

    And pregap4 write in the error window this:

    "interactive_clip::run: child process exited abnormally"

    What does it mean? And how can I use the interactive clipping module, without error message?
    When anyone have an idea... thanks for help:

             steven prazsak
             from Szeged, HU

     
    • jaguarete
      jaguarete
      2005-03-15

      Hi, I am also a beginner in Staden.  I seem to have solved the problem by running the progarm under a one-word-name folder (i.e., C:\Staden).  I used windows explorer to do this. I originally installed the package in the folder "C:\Staden Package", so I deleted the second part of the folder name to "C:\Staden". I guess that "C:\Program_Files" or "C:\Staden_Package" would also work.

      pacarules

       
    • James Bonfield
      James Bonfield
      2005-03-17

      This does sound like a problem with spaces in the filenames.  It certainly used to work in Program Files, so I'm not sure where the problem has crept in.

      However the workaround of using C:\Staden_Package seems suitable until I fix this bug.

      James

       
    • I could make the assembly with interactive clipping, if I made an other output folder, than folder contains the cromatograms. Such simple...

      Steven Prazsak

       
    • On the same note, the same error occurred already with Version2003.0b1. While waiting for it to go way, I use Pregap4 from Version2002.0, installed in a different directory, where there was no problem with the spaces.

      Gabor Igloi

       
    • James Bonfield
      James Bonfield
      2005-07-14

      This particular bug has now been fixed. The problem is in the lib/pregap4/modules/interactive_clip.p4m.

      Search for    -fofn $fofn.tmp   and replace with   -fofn [list $fofn.tmp]   instead.

      James