Also it's been known among the DRBD circle that drbd-0.7 is really meant for kernel-2.6 whereas drbd-0.6 would be more suitable for kernel-2.4.  Since no one ported drbd-0.6 to kernel-2.4, maybe you can try our SSI-1.9.2 preview release for Fedora Core 3 (based on kernel-2.6).


The DRBD packages at OpenSSI are based on drbd-0.7

Roger