Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Problem With SoccerWindow2 & Forum

Help
Sina Amiri
2010-12-12
2014-03-16
  • Sina Amiri
    Sina Amiri
    2010-12-12

    I've an error while configure soccerwindow2-5.0.0 on fedora 14
    I was installed all library that seem useful.
    qt
    qt-devel
    boost
    boost-devel
    automoc
    ...

    what can I do?
    is there anyone can help me?

    [root@SL-PC soccerwindow2-5.0.0]# ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for gcc... gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables...
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking for g++... g++
    checking whether we are using the GNU C++ compiler... yes
    checking whether g++ accepts -g... yes
    checking dependency style of g++... gcc3
    checking for ranlib... ranlib
    configure: enabled Qt4
    configure: set QT4_REQUIRED_VERSION... 4.3.0
    configure: set QT4_REQUIRED_MODULES... QtCore QtGui QtNetwork
    checking for pkg-config... /usr/bin/pkg-config
    configure: check QtCore >= 4.3.0
    checking for Qt4... yes
    configure: check QtGui >= 4.3.0
    checking for Qt4... yes
    configure: check QtNetwork >= 4.3.0
    checking for Qt4... yes
    configure: set QT4_CXXFLAGS... -DQT_SHARED -I/usr/include/QtCore -I/usr/include/QtGui -I/usr/include/QtNetwork
    configure: set QT4_LDFLAGS... -L/usr/X11R6/lib
    configure: set QT4_LDADD... -pthread -lQtGui -lpng -lgobject-2.0 -lSM -lICE -lXi -lXrender -lXrandr -lXfixes -lXcursor -lXinerama -lfontconfig -lfreetype -lXext -lX11 -lQtNetwork -lssl -lcrypto -lQtCore -lpthread -lz -lm -ldl -lgthread-2.0 -lrt -lglib-2.0
    configure: error: You must specify the path to Qt4's moc command.
    
     
    • Sándor Nagy
      Sándor Nagy
      2014-03-16

      I had same problem a few days ago.
      In this case you must specify the path to Qt4's moc command:
      1. Get the path: locate moc-qt4
      2. Use that in: ./configure --with-qt4-moc=/path/to/file

       
      Last edit: Sándor Nagy 2014-03-16