Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#175 missing require_once in imap_general.php (includes solution)

open
None
5
2007-03-31
2007-01-14
James Reid
No

Hi,

I'm trying to get serversidefilters working.

I'm running
- SquirrelMail 1.4.9a
- Compatability 2.0.4
- Server Side Filter 1.5-1.2.7-RC1

If I go into Options and then Mail Filters, I get a blank right hand screen.

When I turned on the debugger I get a "Fatal error: Call to undefined function set_up_language() in /var/www/web7/web/functions/imap_general.php on line 578" error.

Problem can be fixed with by adding "require_once(SM_PATH . 'functions/i18n.php');" to functions/imap_general.php

Regards,
James Reid
james@thereidsonline.com

Discussion

    • labels: 477103 -->
    • milestone: 101717 -->
     
  • Logged In: YES
    user_id=285765
    Originator: NO

    I think this is more a bug in the referenced plugin. Please report it to its author.

     
  • Logged In: YES
    user_id=508228
    Originator: NO

    kink should be right. The core should not need to be modified. First, I suggest using the right version of the Compatibility plugin - see:

    http://squirrelmail.org/wiki/CompatibilityDependencies

     
    • assigned_to: nobody --> pdontthink