#72 MIME and HTML Mail

open
nobody
None
2
2003-03-17
2003-03-10
Ed
No

We have tried this with v1.2.11 and 1.4 with and without
the view as HTML plug-in loaded.

We get a 30 second time-out from apache pointing at
line 714 in mime.php ...

This is typically with email that is HTML content and
has mime-parts some of which are images and base-64
encoded. With mail from sources like our web log
reporting engine this is 100% reproduce-able.

These display properly on regular mail clients like
eudora, ximian, and with another web mail client we
have that's ASP based.

When you have squirrelmail look at the parts [ display
headers and message details ] it displays all of them
fine, the issue seems to be rendering something from
them.

RedHat8
Webserver apache 2.0.40
PHP 4.2.2-8.0.5

IMAP = [other] Rockliffe Mailsite v5.2.5

Test file attached in zip.

Thanks!

Discussion

<< < 1 2 3 (Page 3 of 3)
  • Logged In: YES
    user_id=476981

    Konstantin, I'll take a look at it tonight. I made a view
    modifications but not all works like they suposed todo. Need
    more testing. Basicly the enhancements are just a matter of
    replacing timeconsuming php function calls like preg_match
    by the very fast strpos, substr where possible.

     
  • Logged In: YES
    user_id=285765

    Marc, please don't commit your changes right now, maybe put
    a diff online somewhere so we can review if or what parts of
    the changes should be included before 1.4.0; or we might
    wait with this until after the release of 1.4.0.

     
<< < 1 2 3 (Page 3 of 3)