#126 multiple message delete not working

closed-fixed
nobody
None
5
2006-05-06
2005-09-26
Anonymous
No

When SquirrelMail has multiple pages of messages,
multiple message delete does not work.

1. select several messages
2. delete them
3. select more messages and delete them

Problem: The second set of selected messages are not
deleted. (Changing the page number doesn't correct the
problem.)

Workaround: Click on the Inbox again.

This is in 1.4.4. Did not see the problem mentioned in
the 1.4.5/1.4.6 fixes or in the bug tracker.

PHP 4.3.10.
Linux 2.6.11.7.dn5.p4
Apacheh 1.3.33 (Unix)

Thanks.

Discussion

<< < 1 2 (Page 2 of 2)
  • Tomas Kuliavas
    Tomas Kuliavas
    2006-01-10

    Logged In: YES
    user_id=225877

    It might be hard to reproduce errors with toggle all,
    because they might depend on frame load order.

    Just check right_main.php tests in line 205 and see how they
    handle $use_mailbox_cache=1, when $msgs is not in session.
    showMessagesForMailbox() breaks if last argument is set to
    true and $msgs is not in session. Error in test login can
    cause E_NOTICE level errors and Unknown sender/No subject.

    We can also fix showMessagesForMailbox() instead of fixing
    right_main.php logic.

    Modification in move_messages.php should disable caching on
    every operation with messages.

     
  • Tomas Kuliavas
    Tomas Kuliavas
    2006-05-06

    Logged In: YES
    user_id=225877

    Issue should be fixed in 1.4.7cvs.

     
  • Tomas Kuliavas
    Tomas Kuliavas
    2006-05-06

    • status: open --> closed-fixed
     
  • Chris Lott
    Chris Lott
    2006-12-11

    Logged In: YES
    user_id=98470
    Originator: NO

    I'm writing to ask if this has been fixed in 1.4.7. I use webmail provided by Pair.com; they use SM version 1.4.5. I've been nudging them about this exact issue without any success for many months. Frankly I don't know how to test this one since for me it's not easily repeatable. I thought it was a delete problem since I only noticed it while deleting messages. Later I realized it's actually a caching problem, as others have noted here, because refreshing the inbox causes the headers page to be repainted and then I see the expected messages. So if you can provide some evidence I'd like to point theim at this bug report. Thanks in advance.

     
<< < 1 2 (Page 2 of 2)