#625 Mailbox Viewing Broken

closed-works-for-me
Jason Munro
None
9
2014-08-08
2002-04-16
No

Gee. This is bad, though probably a simple problem.
Seems someone broke something recently. In the CURRENT
cvs, right NOW, when I log in, things are ok. However,
as soon as I check another mailbox (other then INBOX),
viewing ANY mailbox (including INBOX) gives me this
message. It worked in CVS yesterday so I know it ain't
just me!

Here is the messages that came up in my web browser:

Warning: Failed
opening '/home/web/chemistry/staff/thomppj/mail/functio
ns/page_header.php' for inclusion (include_path='')
in ../functions/display_messages.php on line 99

Warning: Failed
opening '/home/web/chemistry/staff/thomppj/mail/config/
config.php' for inclusion (include_path='')
in ../functions/display_messages.php on line 102

Warning: Cannot add header information - headers
already sent by (output started
at ../functions/display_messages.php:99)
in ../functions/i18n.php on line 720

Fatal error: Call to undefined function:
displayhtmlheader()
in ../functions/display_messages.php on line 139

Good luck. Live long and prosper...

Discussion

  • Jason Munro
    Jason Munro
    2002-04-16

    Logged In: YES
    user_id=442854

    Very strange. Checked out with UW and Cyrus, fresh CVS
    install and I cannot reproduce this problem. Everything
    works fine for me. Looking at lines 99 and 102 of
    display_messages I see that the $base_uri was changed to
    $DOCUMENT_ROOT . $base_uri. I wonder if that is part of the
    problem, though that change was made a few weeks back. I am
    also wondering why this function is firing off in the first
    place, it is logout_error(). weird.
    will keep digging.
    jason

     
  • Logged In: YES
    user_id=147248

    Paul: is
    home/web/chemistry/staff/thomppj/mail/functions/page_header.php
    not the correct location of the page_header.php file? Where
    is it located for real?

     
  • Jason Munro
    Jason Munro
    2002-04-17

    Logged In: YES
    user_id=442854

    Paul,
    Konstantin found some major problems with a change made to
    conf.pl not too long ago. It was quoting values it should
    not such as 'false'. This has been fixed in CVS and may very
    well be the cause of your difficulty.

    jason

     
  • Logged In: YES
    user_id=40435

    Strange. Things seem to be working now. If someone fixed
    this, please let me know and I will close the bug.

     
  • Jason Munro
    Jason Munro
    2002-04-18

    • status: open --> closed
     
  • Jason Munro
    Jason Munro
    2002-04-18

    Logged In: YES
    user_id=442854

    appears to have been the bad quoting in conf.pl that caused
    values in config.php to fail if statements.

    closing now

    jason

     
    • status: closed --> open
     
  • Logged In: YES
    user_id=40435

    Argh. It started happening again today. Anyone who wants to
    help me track this down, let me know and I will give you
    access to my mail account and server for debugging.

    captbunzo@squirrelmail.org

     
  • Logged In: YES
    user_id=147248

    Can you please answer my question I've asked way below?
    About whether that is the correct path.

     
  • Logged In: YES
    user_id=147248

    Ended up being an apache misconfiguration problem.

     
    • status: open --> closed-works-for-me