#2525 0@whateverdomain.com

closed-fixed
nobody
Compose (426)
5
2007-10-30
2007-10-23
lau_sh
No

I am using Debian 4.0 (Etch), squirrelmail 1.4.9a-2, PHP 4.4.4-8+etch4, MTA is Postfix 2.3.8-2+ba

I find when I try to send a mail to an email address such 0@whatever.com (0 is zero). After I click "Send", an error come out:
Transaction failed
Server replied: 554 5.5.1 Error: no valid recipients

Please take a look of the attached file which is the log capture from the server.
There is no "RCPT TO" header sent to SMTP server for 0@whatever.com (in the log it is 0@for-demo.com I will attach another log which is send an email to 1@whatever.com (in the log it is 1@for-demo.com). In this test, it does have "RCPT TO".
Please check.

Discussion

  • lau_sh
    lau_sh
    2007-10-23

    log capture for 0@whatever.com

     
  • lau_sh
    lau_sh
    2007-10-23

    • priority: 5 --> 9
     
  • lau_sh
    lau_sh
    2007-10-23

    log capture for 1@whatever.com

     
  • lau_sh
    lau_sh
    2007-10-23

    Logged In: YES
    user_id=1908427
    Originator: YES

    File Added: tcpflow-1@for-demo.com.txt

     
  • Logged In: YES
    user_id=508228
    Originator: NO

    Thank you for your bug report.

    Please don't presume your tracker request to be of highest priority. That comes across as rude.

    See the attached patch (against 1.4.12svn); feedback appreciated.
    File Added: empty_compose_address_fix.patch

     
    • priority: 9 --> 5
     
    • status: open --> closed-fixed
     
  • Logged In: YES
    user_id=508228
    Originator: NO

    The patch has been committed to 1.4.12SVN and 1.5.2SVN. Thanks for the report.