#2433 session_register causes sig11 with php4.4.5

Produces PHP errors
closed-fixed
None
5
2007-02-27
2007-02-20
Takika
No

Please remove session_register from your code, 'cause this is deprecated in php >4.1.0 and cause a sig11 with php4.4.5.

Discussion

  • Logged In: YES
    user_id=285765
    Originator: NO

    Hi,
    I think you're referring to http://bugs.php.net/bug.php?id=40514
    This is a bug in PHP, but since session_register is probably not necessary at all in our code, we can indeed better remove it to prevent problems. I'll check it out.

     
    • assigned_to: nobody --> kink
     
  • Logged In: YES
    user_id=620333
    Originator: NO

    We only have one call to session_register in the code, so clean up should be easy. Looking at the code, it might have been created to avoid the php >4.1.0 compatibility issues, but not done correct as the execution of the function is outside of the if {} brackets.

     
  • Steve Brown
    Steve Brown
    2007-02-26

    Logged In: YES
    user_id=1439821
    Originator: NO

    The workaround for this bug is to do the following:

    1. Open functions/global.php in your favorite editor
    2. Comment out lines 231 and 249
    3. Save changes

    Close this bug since?

     
  • Steve Brown
    Steve Brown
    2007-02-26

    Logged In: YES
    user_id=1439821
    Originator: NO

    I believe that the bug you reported has been fixed in the CVS version. Please either grab a live CVS version or wait and grab an archive of the CVS from tomorrow or later (just to make sure it has the changes in it).

    If the bug does not exist after you update to the CVS version, please close this bug report.

     
  • Steve Brown
    Steve Brown
    2007-02-26

    • status: open --> open-fixed
     
    • status: open-fixed --> closed-fixed