#1792 User created folders do not show up in MOVE drop down menu

closed-fixed
nobody
Folders (317)
9
2005-06-15
2005-06-14
rk2612
No

SM1.4.3.

Created custom folders, which show up in the left
frame .... however, these do not appear to be
hyperlinked.

When I try to move messages in the INBOX, the drop
down box only shows the default folders (INBOX, SENT,
TRASH, DRAFTS). The user created folders are not
visible.

Thanks,

RK

Discussion

  • Logged In: YES
    user_id=620333

    Are the folders subscribed? ie, go to Folders, and look in
    the Subscribe box.

     
  • rk2612
    rk2612
    2005-06-15

    Logged In: YES
    user_id=1296358

    Yes, the folders are subscribed. Thanks,

     
  • rk2612
    rk2612
    2005-06-15

    • priority: 5 --> 9
     
  • rk2612
    rk2612
    2005-06-15

    Logged In: YES
    user_id=1296358

    Looks like I was making the mistake of marking the
    folders "Let this folder contain subfolders". I did not realise
    that a folder that contains other subfolders cannot hold
    messages itself. That sounds a bit silly ... if one goes by the
    Windows style of files and folders.

    Thanks everyone for the response.

     
  • rk2612
    rk2612
    2005-06-15

    • status: open --> closed-fixed
     
  • Logged In: YES
    user_id=620333

    Actually it depends on your IMAP server. As you didn't
    mention it in the original submission we couldn't really
    guess that might be the case. Your IMAP server creates a
    single file to store the emails in it. Linux doesn't allow
    you to have a file and a folder with the same name, so for
    example:

    valcor@titan valcor $ touch mktest
    valcor@titan valcor $ mkdir mktest
    mkdir: `mktest' exists but is not a directory

    This would be the kind of issue your IMAP server would run
    into when trying to create a mail file to store the mail in.
    Other IMAP servers store mail differently, and permit for a
    folder to contain both subfolders, and mail.