#1682 Wordperfect attachments Save but don't Open in IE

open
nobody
5
2004-12-09
2004-12-09
No

Browser: IE 6
PHP version: 4.2.2
Web Server: Apache/2.0.40 (Red Hat Linux)
Squirrelmail Version: 1.4.3a (without XSS patch)
Wordperfect version: 10

When clicking on the filename link of a Wordperfect
attachment and then selecting "Open" in IE 6, the
browser does not open the file in Wordperfect.

When clicking on the download link on the right of the
filename and then pressing "Open", however, the file
does open in Wordperfect as expected.

There seems to be a difference in the headers passed to
the browser to download the file.

Discussion

  • Logged In: YES
    user_id=285765

    Hello,
    Thanks for your report. This can really depend on a lot of
    factors. We would really appreciate it if you can tell us if
    it still exists in our most recent stable release 1.4.7,
    which has a lot of bugs fixed since 1.4.3a. Thanks!

     
  • Tomas Kuliavas
    Tomas Kuliavas
    2006-07-17

    Logged In: YES
    user_id=225877

    IE 6 (WinXP SP2)
    Corel WordPerfect X3
    Microsoft Office 2003
    OpenOffice 2.0.3

    There are two differences between Download link and link on
    attachment name. absolute_dl=true and passed_ent_id=0

    If absolute_dl is not set, SquirrelMail does not force
    download and IE tries to open attachment in associated
    application. I think WordPerfect does not get access to
    cookie and gets "You must be logged page" instead of
    application/wordperfect attachment. Word 2003 opens .doc in
    browser. IE treats OpenDocument and OpenOffice documents
    (application/x-zip-compressed and application/octet-stream
    headers) as zip files and opens them in compressed files
    application.