#1677 Attachment Error in new CVS

closed-fixed
None
5
2005-01-10
2004-12-01
dspoonman
No

I installed CVS: squirrelmail-20041110_0902-
CVS.stable.tar.gz on Sunday 28 November, and ever
since I have installed it any attachment that comes in
that has spaces in the name has "+" symbols where the
spaces are. Is there another CVS coming out soon to
solve this problem or is there something I can do on my
server to aleve this issue. Any help you can give me
would be greatly appreciated.

Discussion

  • Tomas Kuliavas
    Tomas Kuliavas
    2004-12-01

    Logged In: YES
    user_id=225877

    Can you provide more details about your setup?

    webserver, php version, headers of attachment, used translation

     
  • Logged In: YES
    user_id=620333

    I'm not able to confirm this in a CVS update from today.
    Can you ensure you are using the lastest CVS snapshot, and
    restest.

     
  • Tomas Kuliavas
    Tomas Kuliavas
    2004-12-20

    Logged In: YES
    user_id=225877

    please provide details about your setup or bug will be
    closed as unreproducible. SquirrelMail functions should not
    add + instead of spaces.

     
  • Tomas Kuliavas
    Tomas Kuliavas
    2004-12-23

    Logged In: YES
    user_id=225877

    we repeatedly asked to provide more info in order to
    reproduce your problem. You haven't done anything.

    Sorry, bug is closed. We can't reproduce it with information
    that you have provided. If you still have problem, file new
    bug and provide as much information as you can and help us
    to help you.

     
  • Tomas Kuliavas
    Tomas Kuliavas
    2004-12-23

    • status: open --> closed-invalid
     
  • Tomas Kuliavas
    Tomas Kuliavas
    2005-01-09

    • status: closed-invalid --> open
     
  • Tomas Kuliavas
    Tomas Kuliavas
    2005-01-09

    Logged In: YES
    user_id=225877

    browser is Internet Explorer.

    can you open functions/mime.php, find SendDownloadHeaders
    function and replace $filename=urlencode($filename); with
    $filename=rawurlencode($filename);

    Please note that we need your feedback.

     
  • Tomas Kuliavas
    Tomas Kuliavas
    2005-01-10

    • assigned_to: nobody --> tokul
    • status: open --> closed-fixed