Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1629 Wrong folder hierarchy is shown

closed
Folders (317)
5
2006-08-16
2004-08-15
katho
No

Hello,
I have a problem with the hierarchy in the left main
frame. My hierarchy is shown as following:
Incorrect order:
Inbox
Drafts
- Sent
SentSubfolder1
SentSubfolder2
...and so on...
Trash
InboxSubfolder1
InboxSubfolder2
...and so on...

Correct order would be:
Inbox
InboxSubfolder1
InboxSubfolder2
...and so on...
Drafts
- Sent
SentSubfolder1
SentSubfolder2
...and so on...

Is this a known bug?
My system:
OS: WinXP SP2
IMAP: JanaServer 2.4.3
PHP: v5.01
SQ: newest (1.43a)
choosen IMAP-Server in config.php: 'other'

Discussion

  • Logged In: YES
    user_id=620333

    Can you please test with a snapshot from tomorrow. A patch
    was applied to handle some sorting issues.

     
    • assigned_to: nobody --> jangliss
     
  • Logged In: NO

    Currently I'm testing the snapshot 1.5.1 from 2004-08-12,
    the folder hierarchy is shown correct with that snapshot. If
    there will be a new snapshot tomorrow, I'll test it right
    after work.
    What's still wrong:
    - The automatic colour of special folders does not work
    properly, subfolders of my "Sent"-Folder have the colour of
    special folders. Subfolders of my "Inbox"-Folder have the
    correct colour.
    - Within the "Settings"-pages (in german in my case), some
    letters (what are in german called "Umlaute", ,,) are
    shown wrong (e.g. "" looks like ä). Caused by missing
    german localization for this snapshot?
    - Pictures in the subfolder /images have the wrong
    extension, the link points on .jpg, the images have .png.
    Converting the images from PNG to JPG fixed the problem.
    Caused by missing german localization for this snapshot?
    - Only the "default" skin works, changing the skin within
    the settings page doesn't have any effect.

    greets Thomas

     
  • katho
    katho
    2004-08-19

    Logged In: YES
    user_id=1104355

    Sorry, forgotten to login, the comment above it's me :-)

    greets Thomas

     
  • Logged In: YES
    user_id=620333

    Your original report was against 1.4.3a. I meant for you to
    test against a 1.4.x CVS snapshot. 1.5.x has had the folder
    handling code revamped recently, so your mentioned issue
    might not be in there.

    As for the other issues, please open seperate bug tickets
    for each item so they can be properly tracked. Don't forget
    to include as much detail about your setup as you can.

     
  • katho
    katho
    2004-08-19

    Logged In: YES
    user_id=1104355

    I've already tested the snapshot 1.4.4 from 2004-08-12,
    folder hierarchy is not shown correctly there. German
    "Umlaute" are shown correctly.
    Does tomorrow appear a new snapshot from the 1.4.*-tree? If
    so, I'll test it right after work.
    Snapshot 1.4.4 only has the problem with sorting folders in
    the right hierarchy, no other bugs appeard in my test
    environment.

    greets Thomas

     
  • Awais Ahmad
    Awais Ahmad
    2004-12-09

    Logged In: YES
    user_id=870209

    The patch below will fix the issue. Its against 1.4.3a.
    I'll submit it to the patches section as well as a file.

    Cheers,

    Awais Ahmad

    --- imap_mailbox.php.orig Thu Dec 9 23:00:19 2004
    +++ imap_mailbox.php Thu Dec 9 23:00:53 2004
    @@ -118,7 +118,7 @@
    return false;
    }
    /* check for delimiter */
    - if (!substr($parentbox,-1) == $delimiter) {
    + if (substr($parentbox,-1) <> $delimiter) {
    $parentbox.=$delimiter;
    }
    if (substr($subbox,0,strlen($parentbox)) ==
    $parentbox) {
    @@ -610,6 +610,15 @@
    break;
    }
    }
    + /* Find INBOX's children */
    + for($k = 0; $k < $cnt; ++$k) {
    + if
    (isBoxBelow(strtolower($boxesall[$k]['unformatted']),
    'inbox') &&
    + strtolower($boxesall[$k]['unformatted']) <>
    'inbox') {
    + $boxesnew[] = $boxesall[$k];
    + $used[$k] = true;
    + }
    + }
    +
    /* List special folders and their subfolders, if
    requested. */
    if ($list_special_folders_first) {
    for($k = 0; $k < $cnt; ++$k) {

     
  • Logged In: YES
    user_id=620333

    Updating ticket to point to patch...

    Patch 1082558

    Thank you for your submission. I'll review the patch tonight.

     
  • Logged In: YES
    user_id=285765

    Applied to devel and stable branch with a small modification
    (also test on $used in the if). Thanks!

     
    • status: open --> closed
     
  • Logged In: YES
    user_id=285765

    Samuel Wolf writes in private mail (??):

    Hi kink,

    I have the same problem with SquirrelMail (1.4.5) and
    JanaServer (2.4.6.1) how was
    posted here:
    https://sourceforge.net/tracker/?func=detail&aid=1009654&group_id=311&atid=100311

    In moment is it:
    imap_mailbox.php.
    - Look after INBOX
    - Show the special Folders and Subfolders
    - Find the Subfolders from INBOX
    - Find the rest Folders

    I read in a Forum thats the right way:

    - Find the INBOX
    - Find the Subfolders form the INBOX
    - Show the special Folders and Subfolders
    - Find the rest Folders

    Is it a chance to geht an Fix about this problem or get the
    option to say at the
    IMAPServer options "janaserver" in moment it is "other".

    Thanks!

    Greetings from Germany,

    Samuel Wolf

     
    • status: closed --> open
     
  • Logged In: YES
    user_id=285765

    And adds: "Sorry I forgot that I have the problem only when
    I create a NEW subfolder in the INBOX."

     
  • Awais Ahmad
    Awais Ahmad
    2005-07-21

    Logged In: YES
    user_id=870209

    Which version of SM?

    Cheers,

    Awais

     
  • Logged In: YES
    user_id=285765

    We've now released SquirrelMail 1.4.7 with a lot of bugfixes
    since 1.4.3a amongst which probably this one. Can you verify
    that the problem is indeed resolved? Thanks!

     
    • status: open --> pending
     
  • Logged In: YES
    user_id=1312539

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending --> closed