Ahh yes, the good ol' days of 9i on windows.  It's nice how it decides which version of Java you want to use when it puts it's own version in *front* of everything else in your %PATH%.  What I would do in this case is edit squirrel-sql.bat and put something like this at the top just after "@echo off":

set JAVA_HOME=<path to java>

<path to java> should be an absolute path to the folder containing "bin", "lib", "jre" and such.  If <path to java> for you is a path that contains spaces, you may need to adjust quotes in the rest of the script.  If <path to java> does not contain spaces, then all the better.

Rob


On Tue, Feb 21, 2012 at 4:37 PM, hechesspee <harshaputhraya@gmail.com> wrote:

Hi,
I installed Squirrel 3.3.0 to connect to vertica DB and it was fine.
Later I installed Oracle 9i(9.2.0.1.0) client which installed JVM C:\Program
Files\Oracle\jre\1.3.1

Now my squirrel is not working. When I open it, it says - Java Virtual
Machine must be atleast 1.6 where as JVM is 1.3.1

I tried installing the latest version of JVM. But even after the
installation, i got the same message.

Is there any way that I can use squirrel 3.3.0 with oracle 9i being
installed?

Thanks in advance!
Harsha
--
View this message in context: http://old.nabble.com/Squirrel-3.3.0-not-running-after-oracle-9i-installation-tp33367115p33367115.html
Sent from the squirrel-sql-users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Squirrel-sql-users mailing list
Squirrel-sql-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/squirrel-sql-users