We currently connect to 3 iSeries databases using Squirrel version 2.6.4 and we don’t have a disconnect problem.  I do connect using the jt400.jar though.  I changed the JTOpen Driver to use the Extra Class Path of the jt400.jar and Class Name com.ibm.as400.access.AS400JDBCDriver.  This is free from IBM and you might have it already installed if you have IBM iSeries Access for Windows.

 

Bernard Harris

Applications Analyst

Schield Family Brands

715-748-2100 ext. 3520

 

This is a transmission from the Schield Family Brands and may contain information that is privileged and/or confidential.  If you are not the intended addressee, note that any disclosure, copying, distribution, or use of the contents of this message is prohibited.  If you have received this transmission in error, please destroy it and notify the sender immediately at the phone or address listed above.

 


From: rhill@hillconsult.com [mailto:rhill@hillconsult.com]
Sent: Tuesday, August 18, 2009 12:28 PM
To: squirrel-sql-users@lists.sourceforge.net
Subject: Re: [Squirrel-sql-users] Constantly losing connection to AS/400(iSeries) Host

 

Hi.

I have exactly the same problem, and have had to stick with the JDBC-ODBC bridge.

I'd be grateful for a solution too.

Regards
Roger

I’m running against a DB2 database on an AS/400 (iSeries) machine. I’m using the latest JTOPEN driver (6.5.1) and have tried both 3.0.1 and 3.0.2 of SQuirreL.

I can connect, download the tables, and run statements. But if I leave the session idle for few seconds, say 30, the connection is lost. I have tried against two different hosts with the same results.

Using the JDBC-ODBC bridge work fine, except that it seems to reports phantom errors after some statement complete correctly, and I think the JDBC driver would solve some of this.

If anyone has any suggestions on how to fix this problem I sure would like to hear from you. SQuirreL is a great product at a marvelous price.



****************************************
Roger Hill
****************************************