Great, that's it.  As soon as I switch away from Beryl window-manager and
onto KWin (KDE) window manager, SQuirreL works just fine.
[I'll upgrade my Java run-time soon, and re-test.]

Many thanks, and regards...

Dave


On Mon, 2007-03-26 at 21:51 -0400, Robert Manning wrote:
It sounds very similar to an issue which we saw with the JDK where
users who ran any java applications would see what you've described.
The particular troublesome combination was Linux with Sun 1.5/1.6 and
the use of the desktop effects (Compiz).  Others saw this problem when
desktop effects were used in conjunction with nvidia cards and the
nvidia display driver, again on Linux.  I remember hearing that Sun
put out an update to the JDK (a new 1.6 release I believe) that was
supposed to address the issue but that some nvidia users were still
seeing issues.  The problem had to do with how the AWT Frame handled
events with it's native peer on this platform.  You may want to try
disabling desktop effects if they are turned on.  At least one user
reported that as a work-around.

Rob

On 3/26/07, David Cook <david.hubert.cook@verizon.net> wrote:
>
>  Hi -
>
>  I had SQuirreL v2.2 installed on my Linux box, but when I launched it
> (under KDE),
>  it draws the window w/ title-bar, but nothing ever shows up in the
> client-area
>  of the window (i.e. it remains white).
>
>  Since it was a bit out-of-date, I grabbed your new v2.4.1 install-jar, and
> installed that.
>  (I do just the single-user install, which puts it into my /home/<user>
> sub-tree.)
>
>  I'm still seeing the exact same symptom (i.e. nothing shows up in window
> client-area).
>
>  I checked the obvious:
>
>  java -version
>  java version "1.5.0_08"
>  Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)
>  Java HotSpot(TM) Client VM (build 1.5.0_08-b03, mixed mode, sharing)
>  root@2[SQuirreL SQL Client]#
>
>  and another unrelated -jar file executes just fine.
>
>  [The original v2.2 worked a month or so ago...since then, I've
>  upgrade the Linux system (leaving my '/home' partition intact).
>  That usually works...SQuirreL typically runs just fine once I install
>  a newer Linux distro and JRE, etc.]
>
>  Any ideas on what to look at?  [I'm sure its gonna be something simple
>  that I'm overlooking.
>
>  TIA...
>
>  Dave
> -------------------------------------------------------------------------
> Take Surveys. Earn Cash. Influence the Future of IT
> Join SourceForge.net's Techsay panel and you'll get the chance to share your
> opinions on IT & business topics through brief surveys-and earn cash
> http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
> _______________________________________________
> Squirrel-sql-users mailing list
> Squirrel-sql-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/squirrel-sql-users
>
>

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Squirrel-sql-users mailing list
Squirrel-sql-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/squirrel-sql-users